darcs

Issue 1028 scary-looking but harmless scp messages

Title scary-looking but harmless scp messages
Priority bug Status resolved
Milestone Resolved in
Superseder Nosy List darcs-devel, dmitry.kurochkin, kowey, simonpj, thorkilnaur
Assigned To
Topics FauxBug, Regression, SSH, UI

Created on 2008-08-22.12:06:36 by simonpj, last changed 2009-08-27.14:18:47 by admin.

Files
File name Uploaded Type Edit Remove
unnamed simonpj, 2008-08-22.12:06:34 text/html
Messages
msg5635 (view) Author: simonpj Date: 2008-08-22.12:06:34
I have learned to ignore the messages from scp below.  Apparently they are harmless.  But they are unsettling to an uninformed user.  Can I safely ignore these messages, I wonder?  Or maybe something bad will come back to bite me in a week or two if I do?

Could they be suppressed, at least unless you say -v or -debug?

Simon

Identifying repository simonpj@darcs.haskell.org:/home/darcs/ghc format
scp: /home/darcs/ghc/_darcs/format: No such file or directory
Identifying repository simonpj@darcs.haskell.org:/home/darcs/ghc inventory
scp: /home/darcs/ghc/_darcs/prefs/sources: No such file or directory
Reading inventory of repository simonpj@darcs.haskell.org:/home/darcs/ghc
Reading inventory of repository c:/simonpj/darcs/HEAD inventory
Attachments
msg5638 (view) Author: kowey Date: 2008-08-22.12:14:46
Hi Simon,

This has been "fixed" in the lastest darcs.  We do not suppress the messages
because we need scp's stderr output to be passed to the user because of putty
being silly; however, we now inform the user that the messages are harmless and
that they can make them go away by upgrading the server to darcs 2.

In the meantime, you can touch _darcs/format on the server side.
History
Date User Action Args
2008-08-22 12:06:36simonpjcreate
2008-08-22 12:14:55koweysetstatus: unread -> resolved-in-unstable
topic: + SSH, FauxBug, UI, Regression
title: Dracs2 messages -> scary-looking but harmless scp messages
messages: + msg5638
priority: bug
2009-04-22 03:32:42twbsetstatus: resolved-in-unstable -> resolved
nosy: + dmitry.kurochkin, simon, thorkilnaur
2009-08-10 23:43:36adminsetnosy: - dagit
2009-08-25 17:44:21adminsetnosy: + darcs-devel, - simon
2009-08-27 14:18:47adminsetnosy: kowey, darcs-devel, simonpj, thorkilnaur, dmitry.kurochkin