Issue 1049 apply => No more patches in patch bundle! at src/Darcs/Patch/Bundle.lhs:124 (2.0.2+170)

Title apply => No more patches in patch bundle! at src/Darcs/Patch/Bundle.lhs:124 (2.0.2+170)
Priority bug Status resolved
Milestone 2.1.x Resolved in
Superseder Nosy List darcs-devel, dmitry.kurochkin, gwern, kowey, thorkilnaur
Assigned To
Topics Regression

Created on 2008-08-31.07:50:06 by kowey, last changed 2010-06-15.21:48:19 by admin.

msg5831 (view) Author: kowey Date: 2008-08-31.07:50:00
If I apply the following patch bundle to the the darcs darcs repository 

I get the following error:
darcs: bug in darcs!
No more patches in patch bundle! at src/Darcs/Patch/Bundle.lhs:124 compiled Aug
24 2008 20:43:46
I'm unable to check http://darcs.net/maintenance to see if this version is
If it is supported, please report this to bugs@darcs.net
If possible include the output of 'darcs --exact-version'.

Note that I can make this error go away by unpulling "make scan_bundle create a
lazy patch bundle"

The last three patches in my repository are as follows:
Sun Aug 31 00:09:09 BST 2008  Eric Kow <E.Y.Kow@brighton.ac.uk>
  * Add test case for issue844.

Sat Aug 30 20:50:51 BST 2008  David Roundy <droundy@darcs.net>
  * fix bug in --list-options (tab completion).

Sat Aug 30 18:47:22 BST 2008  David Roundy <droundy@darcs.net>
  * fix bug in makeRelative.

My darcs --exact-version is attached.

Adding David because it's his patch :-) and Gwern because he's experienced
similar symptoms with darcs.

If we do fix it, it would be lovely to have some sort of minimal test case for
the suite.
msg5925 (view) Author: kowey Date: 2008-09-07.10:33:16
Since we can reproduce this on a real repository, our current task is to create
a test case for bugs/
msg5935 (view) Author: droundy Date: 2008-09-08.12:37:03
I'm pretty certain this is resolved.
Date User Action Args
2008-08-31 07:50:06koweycreate
2008-09-07 10:33:18koweysetstatus: unread -> needs-reproduction
nosy: droundy, kowey, dagit, gwern
messages: + msg5925
2008-09-08 12:37:06droundysetstatus: needs-reproduction -> resolved
nosy: droundy, kowey, dagit, gwern
messages: + msg5935
2009-08-06 17:59:59adminsetnosy: + markstos, jast, Serware, dmitry.kurochkin, darcs-devel, zooko, mornfall, tommy, simon, beschmi, thorkilnaur, - droundy, gwern
2009-08-06 21:12:13adminsetnosy: - beschmi
2009-08-10 21:48:03adminsetnosy: + gwern, - tommy, markstos, darcs-devel, zooko, jast, Serware, mornfall
2009-08-10 23:44:30adminsetnosy: - dagit
2009-08-25 18:09:11adminsetnosy: + darcs-devel, - simon
2009-08-27 14:10:14adminsetnosy: kowey, darcs-devel, thorkilnaur, gwern, dmitry.kurochkin
2010-06-15 21:48:19adminsetmilestone: 2.1.x
2010-06-15 21:48:19adminsettopic: - Target-2.1