Issue 1224 darcs attempts to convert repositories that are already on darcs-2 format

Title darcs attempts to convert repositories that are already on darcs-2 format
Priority bug Status resolved
Milestone 2.5.0 Resolved in 2.4.x
Superseder Nosy List darcs-devel, dmitry.kurochkin, jaredj, jcpetruzza, kowey, mornfall, thorkilnaur
Assigned To
Topics ProbablyEasy

Created on 2008-11-11.21:04:02 by jcpetruzza, last changed 2010-07-23.18:55:14 by tux_rocker.

msg6656 (view) Author: jcpetruzza Date: 2008-11-11.21:04:00

If one tries to convert a repository that is already on darcs-2  
forma,t darcs blindly attempts to convert it and ends up with an  
inconsistent repository (I can see that there are missing files, at  

I believe that in this case darcs should either:

1) report "already a darcs-2 repository" and quit, or
2) simply perform a get instead of a convert

I've experienced this with both versions 2.0.2 and 2.1.0

msg6692 (view) Author: thorkilnaur Date: 2008-11-19.01:01:10
Thank you very much for this report. I hope that you have not lost any data as a 
result of this problem.

I have sent a patch with a suitable test case that demonstrates the problem in a 
simple case. I have not tried to see what happens when converting a large darcs2 
repository, but it seems to me that this behavior could lead to some unpleasant 
surprises. So, are there anyone who would volunteer to take a look at this?

Thanks to all and best regards
msg8655 (view) Author: kowey Date: 2009-09-02.20:42:25
Hi Thorkil,  It looks like I lost your test patch, sorry! :-(
May I request that you resend?  Our test stuff has evolved a bit in the past
year so if you could maybe just make a new patch, that'd be great.  Latest
instructions here: http://wiki.darcs.net/RegressionTests
msg8789 (view) Author: thorkilnaur Date: 2009-09-11.18:16:14

I have shipped a patch with the (presently failing) test case.

Best regards
msg8797 (view) Author: kowey Date: 2009-09-12.19:27:06
Thanks Thorkil.  This looks like a fairly easy one to fix.  If we don't get it
by the next release, we should at least get to it by the one after that.
msg9289 (view) Author: mornfall Date: 2009-11-15.08:54:42
Fixed by Tomáš Caithaml.
Date User Action Args
2008-11-11 21:04:02jcpetruzzacreate
2008-11-19 01:01:15thorkilnaursetpriority: bug
status: unread -> needs-reproduction
messages: + msg6692
nosy: kowey, dagit, simon, thorkilnaur, dmitry.kurochkin, jcpetruzza
2009-08-10 23:51:29adminsetnosy: - dagit
2009-08-25 17:34:25adminsetnosy: + darcs-devel, - simon
2009-08-27 14:13:38adminsetnosy: kowey, darcs-devel, thorkilnaur, dmitry.kurochkin, jcpetruzza
2009-09-02 20:42:29koweysettopic: + ProbablyEasy
nosy: + jaredj
messages: + msg8655
assignedto: thorkilnaur
2009-09-11 18:16:16thorkilnaursetnosy: kowey, darcs-devel, thorkilnaur, jaredj, dmitry.kurochkin, jcpetruzza
messages: + msg8789
2009-09-11 19:23:25thorkilnaursetstatus: needs-reproduction -> unknown
nosy: kowey, darcs-devel, thorkilnaur, jaredj, dmitry.kurochkin, jcpetruzza
assignedto: thorkilnaur ->
2009-09-12 19:27:13koweysetstatus: unknown -> needs-implementation
nosy: kowey, darcs-devel, thorkilnaur, jaredj, dmitry.kurochkin, jcpetruzza
topic: + Target-2.5
messages: + msg8797
2009-11-15 08:54:47mornfallsetstatus: needs-implementation -> resolved
nosy: + mornfall
messages: + msg9289
2010-06-15 20:51:45adminsetmilestone: 2.5.0
2010-06-15 20:58:56adminsettopic: - Target-2.5
2010-07-23 18:55:14tux_rockersetresolvedin: 2.4.x