darcs

Issue 1535 packed storage combining many small files into fewer larger ones

Title packed storage combining many small files into fewer larger ones
Priority feature Status duplicate
Milestone Resolved in
Superseder Nosy List darcs-devel, dmitry.kurochkin, ertai, kowey, mndrix, mornfall, thorkilnaur
Assigned To
Topics Performance

Created on 2009-08-18.08:33:45 by kowey, last changed 2014-01-21.19:07:53 by gh.

Messages
msg8227 (view) Author: kowey Date: 2009-08-18.08:33:41
Needs design, discussion, implementation.  I'm just noting this here because
it's one of the big performance things that we keep talking about.

See also
 * http://mornfall.net/blog/designing_storage_for_darcs.html
 * http://wiki.darcs.net/PacksSpecification
msg14753 (view) Author: markstos Date: 2011-10-13.12:57:41
How is this different from "optimize --packs" ?
msg17140 (view) Author: gh Date: 2014-01-21.19:07:52
Closing it as "duplicate" of packs, which already has tickets.
History
Date User Action Args
2009-08-18 08:33:45koweycreate
2009-08-25 18:15:29adminsetnosy: + darcs-devel, - simon
2009-08-26 13:11:00koweylinkissue987 superseder
2009-08-27 14:32:51adminsetnosy: kowey, darcs-devel, thorkilnaur, ertai, dmitry.kurochkin, mornfall
2009-09-02 14:33:53koweylinkissue152 superseder
2009-10-23 22:40:57adminsetnosy: + nicolas.pouillard, - ertai
2009-10-24 00:06:02adminsetnosy: + ertai, - nicolas.pouillard
2011-10-13 12:57:41markstossetmessages: + msg14753
2012-02-24 15:17:23mndrixsetnosy: + mndrix
2014-01-21 19:07:53ghsetstatus: needs-reproduction -> duplicate
messages: + msg17140