darcs

Issue 1597 changes --context with matchers

Title changes --context with matchers
Priority feature Status duplicate
Milestone Resolved in
Superseder darcs changes --context with matchers
View: 1055
Nosy List ahey, darcs-devel, dmitry.kurochkin, jamesdsadler, kowey, thorkilnaur, tommy
Assigned To
Topics Matchers

Created on 2009-09-04.17:55:06 by kowey, last changed 2010-03-31.13:00:47 by kowey.

Messages
msg8694 (view) Author: kowey Date: 2009-09-04.17:54:59
Note that this bug is mutually exclusive with issue1534.
It'd be a good idea to refer to msg1579 from issue428.

The problem is that changes --context is ill-defined with matchers like -p and
--last.  One solution (issue1534) would be to refuse to accept matchers.

Another solution would be to define a clear meaning for changes --context -p
(etc) and then implement it.

I'll leave this need-action for somebody to work out a proposal.

(One proposal: the matchers mean 'give me a context which includes at least
these patches')
msg10593 (view) Author: kowey Date: 2010-03-31.13:00:46
I think this is a duplicate of issue1055, but I could be wrong
History
Date User Action Args
2009-09-04 17:55:07koweycreate
2009-09-04 17:57:15koweylinkissue428 superseder
2010-03-31 13:00:47koweysetstatus: needs-reproduction -> duplicate
superseder: + darcs changes --context with matchers
messages: + msg10593
2010-03-31 13:11:27koweyunlinkissue428 superseder