darcs

Issue 1659 whatsnew -l falsely(?) reports R files (2.3.1)

Title whatsnew -l falsely(?) reports R files (2.3.1)
Priority bug Status resolved
Milestone Resolved in
Superseder Nosy List darcs-devel, dmitry.kurochkin, kowey, mornfall, zooko
Assigned To
Topics Regression

Created on 2009-10-25.20:30:28 by zooko, last changed 2009-11-14.12:51:37 by mornfall.

Files
File name Uploaded Type Edit Remove
pycryptopp.7z zooko, 2009-10-31.04:35:35 application/x-7z-compressed
pycryptopp.7z zooko, 2009-10-31.04:37:32 application/x-7z-compressed
zooko.log.txt zooko, 2009-10-31.04:43:40 text/plain
Messages
msg9031 (view) Author: zooko Date: 2009-10-25.20:30:26
HACL yukyuk:~/playground/pycryptopp/trunk$ darcs whatsnew
No changes!
HACL yukyuk:~/playground/pycryptopp/trunk$ darcs whatsnew -sl
R ./pycryptopp.egg-info/stdeb.cfg
R ./pycryptopp.egg-info/
HACL yukyuk:~/playground/pycryptopp/trunk$ darcs revert
There are no changes to revert!
Finished reverting.
HACL yukyuk:~/playground/pycryptopp/trunk$ darcs whatsnew -sl
R ./pycryptopp.egg-info/stdeb.cfg
R ./pycryptopp.egg-info/
HACL yukyuk:~/playground/pycryptopp/trunk$ darcs --version
2.3.1 (+ 271 patches)
msg9032 (view) Author: kowey Date: 2009-10-25.21:15:37
Interesting.  Could you send us the contents of _darcs/patches/pending?
Also, is this a hashed repository? darcs-2?
msg9034 (view) Author: zooko Date: 2009-10-25.21:28:45
HACL yukyuk:~/playground/pycryptopp/trunk$ cat _darcs/patches/pending
{
}
HACL yukyuk:~/playground/pycryptopp/trunk$ cat _darcs/patches/pending.tentative 
{
}
HACL yukyuk:~/playground/pycryptopp/trunk$ darcs query repo
          Type: darcs
        Format: darcs-1.0
          Root: /home/zooko/playground/pycryptopp/trunk
      Pristine: PlainPristine "_darcs/pristine"
         Cache: thisrepo:/home/zooko/playground/pycryptopp/trunk,
cache:/home/zooko/.darcs/cache
boringfile Pref: .darcs-boringfile
        Author: zooko@zooko.com
Default Remote: zooko@dev.allmydata.com:/home/darcs/pycryptopp/trunk
   Num Patches: 674

What?  Darcs-1.0 format?  I thought I had upgraded all my repos to hashed-format...
msg9035 (view) Author: zooko Date: 2009-10-25.21:56:24
switched to hashed-format, same problem:

 yukyuk:~/playground/pycryptopp/trunk-hashedformat$ dw -sl pycryptopp.egg-info
What's new in "pycryptopp.egg-info":

R ./pycryptopp.egg-info/stdeb.cfg
R ./pycryptopp.egg-info/
 yukyuk:~/playground/pycryptopp/trunk-hashedformat$ darcs revert pycryptopp.egg-info
Reverting changes in "pycryptopp.egg-info"..

There are no changes to revert!
Finished reverting.
 yukyuk:~/playground/pycryptopp/trunk-hashedformat$ dw -sl pycryptopp.egg-info
What's new in "pycryptopp.egg-info":

R ./pycryptopp.egg-info/stdeb.cfg
R ./pycryptopp.egg-info/
 yukyuk:~/playground/pycryptopp/trunk-hashedformat$ darcs --version
2.3.1 (+ 271 patches)
 yukyuk:~/playground/pycryptopp/trunk-hashedformat$ darcs query repo
          Type: darcs
        Format: hashed
          Root: /home/zooko/playground/pycryptopp/trunk-hashedformat
      Pristine: HashedPristine
         Cache: thisrepo:/home/zooko/playground/pycryptopp/trunk-hashedformat,
cache:/home/zooko/.darcs/cache
boringfile Pref: .darcs-boringfile
Default Remote: /home/zooko/playground/pycryptopp/trunk
   Num Patches: 674
msg9043 (view) Author: kowey Date: 2009-10-26.10:59:13
This is a really nice one, Zooko.  Can you check to see if darcs-2.2 behaves the
same way?
msg9078 (view) Author: zooko Date: 2009-10-29.21:01:56
HACK Wonwin-McBrootles-Computer:~/playground/pycryptopp/trunk-hashedformat$
/usr/local/stow/darcs.net-2009-10-17/bin/darcs --version
2.3.1 (+ 264 patches)
HACK Wonwin-McBrootles-Computer:~/playground/pycryptopp/trunk-hashedformat$ time
/usr/local/stow/darcs.net-2009-10-17/bin/darcs whatsnew -sl
M ./pycryptopp/cipher/aes.py +12
R ./pycryptopp.egg-info/stdeb.cfg
R ./pycryptopp.egg-info/

real    0m1.001s
user    0m0.217s
sys     0m0.072s
HACK Wonwin-McBrootles-Computer:~/playground/pycryptopp/trunk-hashedformat$
/usr/local/stow/darcs-2.2.0/bin/darcs --version
2.2.0 (release)
HACK Wonwin-McBrootles-Computer:~/playground/pycryptopp/trunk-hashedformat$ time
/usr/local/stow/darcs-2.2.0/bin/darcs whatsnew -sl
M ./pycryptopp/cipher/aes.py +12
a ./pycryptopp.egg-info/PKG-INFO
a ./pycryptopp.egg-info/SOURCES.txt
a ./pycryptopp.egg-info/dependency_links.txt
a ./pycryptopp.egg-info/not-zip-safe
a ./pycryptopp.egg-info/requires.txt
a ./pycryptopp.egg-info/top_level.txt

real    0m0.614s
user    0m0.427s
sys     0m0.384s
msg9080 (view) Author: kowey Date: 2009-10-30.09:31:08
It looks like we have a regression here.

Petr, could you look into this and let me know if there is any chance this could
be related to the recent hashed-storage work?

Meanwhile: Zooko, perhaps you could make a tarball and attach it if it's not too
big.  Better yet would be to try to boil this down into a minimal example.
msg9083 (view) Author: mornfall Date: 2009-10-30.11:54:42
Minimal example would be nice, but I think a reproducer would be enough. It may
also be that this is fixed by the pending LookForAdds performance regression
fix, although it does hint at something changing in the semantics of whatsnew.

Interestingly though, the code for whatsnew --look-for-adds in 2.3 is using the
complete old codepath, not involving hashed-storage at all.

But I now see this is not 2.3 afterall, but something that's got even more
patches over 2.3.1 than HEAD (??). Zooko, what darcs is that please?
msg9084 (view) Author: mornfall Date: 2009-10-30.11:55:32
Hm, nevermind, it's probably HEAD from a while back, it seems that darcs --
msg9094 (view) Author: kowey Date: 2009-10-30.16:52:55
OK, I'm moving the ball back to Zooko's court for a reproducible test case (a
tarball of the present repo would be perfect!)

By the way, Petr, now that we've tracked down the vexing issue1653, do you
remember what you were trying to say in msg9084 just now?
msg9095 (view) Author: mornfall Date: 2009-10-30.18:19:32
Eric, I just wanted to say that it seems that my darcs --version still doesn't
quite work as I'd like it to, for some reason (because my HEAD of darcs says
+273 patches, and that's 7 or so extra patches that are not on mainline yet,
but darcs chan --from-tag=. --count says 281 or so, which matches up with
Zooko's numbers).
msg9096 (view) Author: zooko Date: 2009-10-31.04:36:21
Okay this repo that I uploaded on "2009-10-31.04:35:35" is the one that has this
strange behavior.
msg9116 (view) Author: mornfall Date: 2009-10-31.13:01:34
Zooko, the problem with the R files in your repository with new darcs is
because this "pycryptopp.egg-info" directory is marked as boring. I guess this
is a bug in my new code where boring takes preference over what's already in
the repo. I'll investigate on how to fix that.

As for the other problem with unapplicable patches, that's reasonable given
that you have different patches in the branches under the same names. This
either tends to lead to "bug in get_extra" or unapplicable hunks (or both).
That's why the documentation says that you should never amend published
patches.
msg9125 (view) Author: kowey Date: 2009-10-31.17:24:52
Just an admin note: I've copied/moved messages related to the error applying to
hunk to issue1669.  Please continue that discussion there :-)

Looks like we're waiting for Petr's patch to be applied for this one.
msg9262 (view) Author: mornfall Date: 2009-11-14.12:51:35
I believe Reinier applied this particular fix.
History
Date User Action Args
2009-10-25 20:30:28zookocreate
2009-10-25 21:15:40koweysetstatus: unknown -> waiting-for
priority: bug
nosy: + kowey
messages: + msg9032
topic: + ThePendingPatch
assignedto: zooko
2009-10-25 21:28:47zookosetmessages: + msg9034
2009-10-25 21:56:26zookosetmessages: + msg9035
2009-10-26 10:59:15koweysetmessages: + msg9043
2009-10-29 21:02:00zookosetmessages: + msg9078
2009-10-30 09:31:12koweysetstatus: waiting-for -> needs-reproduction
title: whatsnew -sl says R files but revert doesn't change anything -> whatsnew -l falsely(?) reports R files (2.3.1)
nosy: + mornfall
messages: + msg9080
topic: + Regression, - ThePendingPatch
assignedto: zooko -> mornfall
2009-10-30 11:54:44mornfallsetmessages: + msg9083
2009-10-30 11:55:34mornfallsetmessages: + msg9084
2009-10-30 16:52:58koweysetstatus: needs-reproduction -> waiting-for
assignedto: mornfall -> zooko
messages: + msg9094
2009-10-30 18:19:34mornfallsetmessages: + msg9095
2009-10-31 04:29:42zookosetfiles: + pycryptopp.7z
2009-10-31 04:34:33zookosetfiles: - pycryptopp.7z
2009-10-31 04:35:37zookosetfiles: + pycryptopp.7z
2009-10-31 04:36:23zookosetmessages: + msg9096
2009-10-31 04:37:34zookosetfiles: + pycryptopp.7z
2009-10-31 04:40:21zookosetmessages: + msg9097
2009-10-31 04:43:45zookosetfiles: + zooko.log.txt
messages: + msg9098
2009-10-31 13:01:37mornfallsetstatus: waiting-for -> has-patch
messages: + msg9116
2009-10-31 15:14:04zookosetmessages: + msg9118
2009-10-31 15:18:09zookosetmessages: + msg9119
2009-10-31 17:19:56adminsetmessages: - msg9097
2009-10-31 17:20:31adminsetmessages: - msg9098
2009-10-31 17:22:03adminsetmessages: - msg9118, msg9119
2009-10-31 17:24:54koweysetassignedto: zooko ->
messages: + msg9125
2009-11-14 12:51:37mornfallsetstatus: has-patch -> resolved
messages: + msg9262