darcs

Issue 1862 darcs convert fails on HEAD > 2.4.4 (Couldn't fetch XXX in subdir pristine.hashed)

Title darcs convert fails on HEAD > 2.4.4 (Couldn't fetch XXX in subdir pristine.hashed)
Priority bug Status duplicate
Milestone Resolved in
Superseder noslurps darcs can create pristine that's missing hashed-files
View: 1860
Nosy List attila.lendvai, dmitry.kurochkin, gh, kowey, mornfall
Assigned To mornfall
Topics Hashed, Regression

Created on 2010-06-06.11:42:49 by kowey, last changed 2010-06-06.14:05:00 by mornfall.

Messages
msg11161 (view) Author: gh Date: 2010-05-30.11:07:10
I obliterated all patches not related to the merger patch causing the
problem, and uploaded a hased version of the repo at :
http://progg.free.fr/darcs/smaller-ddc-head

Now, during "darcs convert", the Zlib problem does no longer happen, but
instead I have another problem, right after the lossy conversion:

======================
Directory '/home/guillaume/repos/smaller-ddc-head' already exists,
creating repository as '/home/guillaume/repos/smaller-ddc-head_4'

lossy conversion of complicated conflict:
merger 0.0 (
hunk ./test/Graphics/N-Body/Boxed/Main.build 6
+
+extra-link-lib-dirs:
+	/usr/X11R6/lib
hunk ./test/Graphics/N-Body/Boxed/Main.build 6
+
+extra-link-lib-dirs:
+	/usr/X11R6/lib
)
lossy conversion of complicated conflict:
merger 0.0 (
hunk ./test/Graphics/N-Body/Unboxed/Main.build 6
+
+extra-link-lib-dirs:
+	/usr/X11R6/lib
hunk ./test/Graphics/N-Body/Unboxed/Main.build 6
+
+extra-link-lib-dirs:
+	/usr/X11R6/lib
)
lossy conversion of complicated conflict:
merger 0.0 (
hunk ./test/Graphics/Simple/Main.build 6
+
+
+extra-link-lib-dirs:
+	/usr/X11R6/lib
hunk ./test/Graphics/Simple/Main.build 6
+
+extra-link-lib-dirs:
+	/usr/X11R6/lib
)
                                          
darcs failed:  Couldn't fetch
`3d8f84722cab37e13c253037d35e7bc2f0de4a73d71826147c09712562192358'
in subdir pristine.hashed from sources:

thisrepo:/home/guillaume/repos/smaller-ddc-head_4
cache:/home/guillaume/.darcs/cache

An error may have left your new working directory an inconsistent
but recoverable state. You should be able to make the new
repository consistent again by running darcs revert -a.

======================

This happened with a cold cache.
This does not happen with darcs2.3.1 and darcs 2.4.3.
Doing darcs revert -a in the new repo does not change anything, and
darcs HEAD check does not say anything wrong, but darcs2.3.1 check says:

===============

$ darcs2.3.1 check
Looks like we have a difference...                                     
       
                         
darcs failed:  Couldn't fetch
`3d8f84722cab37e13c253037d35e7bc2f0de4a73d71826147c09712562192358'
in subdir pristine.hashed from sources:

thisrepo:/home/guillaume/repos/smaller-ddc-head_4
cache:/home/guillaume/.darcs/cache

========================

But darcs2.4.3 says the repository is fine! I'll test with darcs2.4.4.
msg11162 (view) Author: gh Date: 2010-05-30.11:27:42
Darcs2.4.4 does not complain.
msg11163 (view) Author: gh Date: 2010-05-30.12:38:50
Tarball of the smaller repo (~6 MBytes) :
http://progg.free.fr/darcs/smaller-ddc-head.tar.bz2
msg11254 (view) Author: kowey Date: 2010-06-06.11:42:46
Splitting issue 1853
msg11256 (view) Author: kowey Date: 2010-06-06.11:49:54
Hi Petr, if you do a darcs convert on the
http://progg.free.fr/darcs/smaller-ddc-head.tar.bz2 repo that Guillaume
kindly provided, you'll get a yucky hashed error that looks potentially
noslurps related.

Is this related to some of our recent troubles, such as issue1857?
msg11257 (view) Author: kowey Date: 2010-06-06.11:55:29
I'll also note, Guillaume - if you could work out to turn that 138 patch
repo into an ultra-minimal one created through an automated regression
test, that would be extremely useful.  By rights, this should be one of
the next actions taken, along with Petr's investigations.
msg11261 (view) Author: mornfall Date: 2010-06-06.14:04:59
This is the same as 1860, that is a rename/flush conflict in h-s. I have 
a fix, I am trying to get a regression test that would actually fail with 
the old code.
History
Date User Action Args
2010-06-06 11:42:49koweycreate
2010-06-06 11:43:47koweysettitle: darcs convert fails on HEAD > 2.4.4 (Zlib premature end of compressed stream) -> darcs convert fails on HEAD > 2.4.4 (Couldn't fetch XXX in subdir pristine.hashed)
2010-06-06 11:45:19adminsetmessages: + msg11161, msg11162, msg11163
2010-06-06 11:49:56koweysettopic: + Hashed
assignedto: mornfall
messages: + msg11256
nosy: + mornfall
2010-06-06 11:55:29koweysetmessages: + msg11257
2010-06-06 14:05:00mornfallsetstatus: needs-reproduction -> duplicate
superseder: + noslurps darcs can create pristine that's missing hashed-files
messages: + msg11261