darcs

Issue 2086 darcs does not preserve _darcs/index permissions

Title darcs does not preserve _darcs/index permissions
Priority bug Status resolved
Milestone Resolved in
Superseder Nosy List ganesh, kowey, mornfall
Assigned To
Topics

Created on 2011-07-10.18:16:13 by kowey, last changed 2015-07-02.06:15:04 by ganesh.

Messages
msg14579 (view) Author: kowey Date: 2011-07-10.18:16:12
Needs regression test.  Assigned to me because I could have sworn I'd seen 
the same thing.

https://twitter.com/#!/rhesse/status/89883848162287616
msg14582 (view) Author: kowey Date: 2011-07-10.21:08:22
test submitted as patch640, now needs investigation, perhaps hashed-
storage?
msg18546 (view) Author: bf Date: 2015-06-17.21:36:33
The test for this actually suceeds (both darcs1 and darcs2 format).
msg18650 (view) Author: ganesh Date: 2015-07-01.16:21:25
The text of the tweet is "Dear darcs programmers, quit fucking with my 
file permissions. I want 664 on the index. There's no reason that's 
dangerous. Stop changing it"
msg18659 (view) Author: ganesh Date: 2015-07-02.06:09:27
The test for this fails on my machine as-is, because my default 
umask is 022. If I change it to 002, or add an explicit --umask 002 
to the second record command in the test, then it passes.

Technically speaking a umask is only supposed to affect the 
permissions for newly-created files, so it may be that the original 
reporters are expecting to be able to change the permissions on 
_darcs/index after creation to something that conflicts with their 
umask - e.g. 0664 with a umask of 022 - and have that be preserved. 
In practice that doesn't work because I think darcs recreates the 
index file when it updates it.

If anyone cares about that scenario please reopen this bug for 
discussion otherwise I'm going to change the test to be robust 
against the runner's umask and leave the bug resolved.
History
Date User Action Args
2011-07-10 18:16:13koweycreate
2011-07-10 21:08:22koweysetnosy: + mornfall
messages: + msg14582
assignedto: kowey ->
2015-06-17 21:36:34bfsetmessages: + msg18546
2015-06-17 21:49:30bfsetstatus: needs-reproduction -> resolved
2015-07-01 16:21:26ganeshsetstatus: resolved -> unknown
messages: + msg18650
2015-07-02 06:09:29ganeshsetstatus: unknown -> resolved
messages: + msg18659
2015-07-02 06:15:04ganeshsetnosy: + ganesh