darcs

Issue 2135 Annotate of a file causes network activity, when changes -v doesn't, in a lazy repo

Title Annotate of a file causes network activity, when changes -v doesn't, in a lazy repo
Priority bug Status needs-implementation
Milestone 2.12.0 Resolved in
Superseder Nosy List owst
Assigned To owst
Topics

Created on 2012-01-22.01:17:52 by owst, last changed 2016-04-04.14:53:45 by gh.

Messages
msg15045 (view) Author: owst Date: 2012-01-22.01:17:51
changes -v prints its output without touching the network, but annotate
is sitting here performing network activity (to darcs.net, I'm
annotating a Darcs source file), presumably grabbing patches.

There is a line in the output marked as "unknown", mornfall suggests
this could be a hint to the cause (maybe line-splitting/coverage checking).
msg15049 (view) Author: noreply Date: 2012-01-22.15:11:00
The following patch sent by Owen Stephens <darcs@owenstephens.co.uk> updated issue issue2135 with
status=has-patch

* Resolve issue2135: Don't keep trying to annotate a file, after processing the patch that added the file. 
Ignore-this: 7b74469cfef3d30181d2830a9cbb7171
msg15050 (view) Author: owst Date: 2012-01-22.15:25:52
This is rather tricky to test, since it requires some lines to be
un-annotated, at the point of the addfile patch. 

Testing manually and watching for network activity suggests it is
working as expected though.
msg15358 (view) Author: gh Date: 2012-03-19.21:08:06
Setting it back from "resolved" to "need-testcase" since I rollbacked
the unsatisfactory fix patch697 that did not prevent the appearance of
"unknown" lines in annotate.
msg15397 (view) Author: noreply Date: 2012-03-24.16:31:03
The following patch sent by Owen Stephens <darcs@owenstephens.co.uk> updated issue issue2135 with
status=resolved;resolvedin=2.8.0 HEAD

* Resolve issue2135: Don't keep trying to annotate a file, after processing the patch that added the file. 
Ignore-this: 7b74469cfef3d30181d2830a9cbb7171
msg15407 (view) Author: gh Date: 2012-03-28.22:22:00
Reopening the bug since its first fix has been rollbacked.
History
Date User Action Args
2012-01-22 01:17:52owstcreate
2012-01-22 15:11:01noreplysetstatus: needs-testcase -> has-patch
messages: + msg15049
2012-01-22 15:25:53owstsetstatus: has-patch -> resolved
messages: + msg15050
2012-03-19 21:08:07ghsetstatus: resolved -> needs-testcase
messages: + msg15358
2012-03-24 16:31:04noreplysetstatus: needs-testcase -> resolved
messages: + msg15397
resolvedin: 2.8.0
2012-03-28 22:22:01ghsetstatus: resolved -> needs-implementation
messages: + msg15407
2016-04-04 14:53:45ghsetmilestone: 2.12.0
resolvedin: 2.8.0 ->