darcs

Issue 2268 darcs 2.8 does not build from cabal on Mac OS X

Title darcs 2.8 does not build from cabal on Mac OS X
Priority Status needs-reproduction
Milestone Resolved in
Superseder Nosy List crm, owst
Assigned To
Topics

Created on 2012-11-06.02:45:47 by rpg, last changed 2013-07-12.13:46:16 by rpg.

Messages
msg16292 (view) Author: rpg Date: 2012-11-06.02:45:44
1. Summarise the issue (what were doing, what went wrong?)

Tried to build darcs using cabal install darcs.

Failed with several dependency problems:
cabal: Error: some packages failed to install:
HTTP-4000.2.6 depends on parsec-3.1.3 which failed to install.
darcs-2.8.3 depends on hashed-storage-0.5.10 which failed to install.
hashed-storage-0.5.10 failed during the building phase. The exception 
was:
ExitFailure 1
haskeline-0.6.4.7 failed during the building phase. The exception was:
ExitFailure 1
network-2.3.2.0 depends on parsec-3.1.3 which failed to install.
parsec-3.1.3 failed during the building phase. The exception was:
ExitFailure 1

I also see:
Storage/Hashed/Monad.hs:34:8:
    Could not find module `Control.Monad.RWS.Strict'
    Perhaps you haven't installed the profiling libraries for package 
`mtl-2.1.2'?
    Use -v to see a list of the files searched for.

and

Text/Parsec/Prim.hs:78:8:
    Could not find module `Control.Monad.Error.Class'
    Perhaps you haven't installed the profiling libraries for package 
`mtl-2.1.2'?
    Use -v to see a list of the files searched for.



2. What behaviour were you expecting instead?

successful build

3. What darcs version are you using? (Try: darcs --exact-version)

trying to upgrade from pre-built 2.5 to 2.8

4. What operating system are you running?

Mac OSX Lion.  Fresh download of Haskell framework.
msg16293 (view) Author: rpg Date: 2012-11-06.02:47:39
Is this a dependency bug that somehow something in whatever "mtl" is, is 
not correctly configured in the build instructions?
msg16294 (view) Author: rpg Date: 2012-11-06.03:54:03
OK: here's why: the .cabal/config file that the Haskell Platform writes 
for you has Profiling: True in it.

For some reason (I don't know why), it is not able to build mtl with 
profiling on.  So it fails.  I found this StackOverflow question that 
led me to turn off profiling, and then darcs builds successfully:
http://stackoverflow.com/questions/8954566/cannot-install-yesod-haskell-
web-framework-on-mac-osx

Suggestion: add this to the FAQ about building darcs, since it's really 
obscure.
msg16295 (view) Author: owst Date: 2012-11-06.10:51:27
Hi,

Thanks for the bug report and tracking down the issue. I've updated the
"compiling from source" section here http://darcs.net/Binaries

Cheers,
Owen.
msg16896 (view) Author: simon Date: 2013-07-11.19:52:46
macph and I can't reproduce this (osx 10.7.5 here; cf today's #darcs log). 
The proposed workaround on the wiki page seems unnecessary and/or needs 
more explanation. I'd say remove it from the wiki until this has been 
clarified further.
msg16897 (view) Author: crm Date: 2013-07-12.10:39:12
I played around and can't reproduce the problem on following configurations 
:

Mac OS X 10.7.5 Lion, Haskell platform 2013.2.0.0 32 bit and 2012.4.0.0 64 
bit, Xcode 4.6.2 with the latest CLI tools.
Mac OS X 10.8.4 Mountain Lion, Haskell platform 2013.2.0.0 64 bit, Xcode 
4.6.3 with the latest CLI tools.

I can build darcs 2.8.4 (+ 1 patch) (including profiling libraries) on booth 
systems using cabal install darcs .... I use no Fink, no MacPorts and no 
Homebrew (this tools produces often problems with file permissions, folder 
permission, other paths).

There are more details needed.
History
Date User Action Args
2012-11-06 02:45:47rpgcreate
2012-11-06 02:47:40rpgsetmessages: + msg16293
2012-11-06 03:54:05rpgsetmessages: + msg16294
2012-11-06 10:51:28owstsetstatus: unknown -> resolved
messages: + msg16295
2013-07-11 19:52:47simonsetstatus: resolved -> needs-reproduction
nosy: + owst
messages: + msg16896
2013-07-12 10:39:13crmsetnosy: + crm
messages: + msg16897
2013-07-12 13:46:16rpgsetnosy: - rpg