darcs

Issue 2521 fix cabal new-build for cabal < 2.0

Title fix cabal new-build for cabal < 2.0
Priority Status resolved
Milestone Resolved in 2.14.0 HEAD
Superseder Nosy List fa-ml
Assigned To
Topics

Created on 2017-01-22.15:21:03 by fa-ml, last changed 2017-10-12.16:44:52 by gh.

Files
File name Uploaded Type Edit Remove
fixes-build-with-cabal-new_build.dpatch fa-ml, 2017-01-22.15:21:01 text/plain
Messages
msg19342 (view) Author: fa-ml Date: 2017-01-22.15:21:02
A small patch to fix building darcs with cabal new-build (1.24).
New stanza should be ignored without errors using Cabal >= 1.20
-F
Attachments
msg19566 (view) Author: bf Date: 2017-08-12.19:10:15
I am using new-build since quite a while and had no problems. It is
unclear to me what the purpose is of the extra stanza .
msg19570 (view) Author: ganesh Date: 2017-08-12.20:49:26
From what I recall, it's reproducible with cabal-install 1.24 but not 
cabal-install 2.0 (still in beta).
msg19574 (view) Author: bf Date: 2017-08-13.00:50:00
Ah, that may be it. I am using the cabal-head package for ubuntu.
msg19594 (view) Author: bf Date: 2017-08-15.15:56:53
I have pushed the patch to screened.
msg19601 (view) Author: bf Date: 2017-08-16.18:41:54
fa-ml writes (personal communication):

"""
I have talked with cabal devs (in the person or Herbert Valerio
Riedel).

Long story short: the stanza will become mandatory once cabal-version
hits 1.24.

I asked why using HEAD required no change, answer was: "It is probably
just accidental/coincidental".

So I believe the problem stands, and users who are currently using
some cabal versions (1.24+ and soon, HEAD) will get bitten by this.
"""

I guess that means we have to bite the bullet and accept this patch even
though it burdens us with duplicate dependency information in the cabal
file?
msg19602 (view) Author: bf Date: 2017-08-16.18:43:39
I checked and found that my cabal-head is now at version 2.1 which
explains why it works for me w/o the extra stanza.
History
Date User Action Args
2017-01-22 15:21:03fa-mlcreate
2017-08-12 19:10:17bfsetstatus: unknown -> needs-reproduction
messages: + msg19566
2017-08-12 20:49:27ganeshsetmessages: + msg19570
2017-08-13 00:50:01bfsetmessages: + msg19574
2017-08-15 15:56:54bfsetstatus: needs-reproduction -> has-patch
messages: + msg19594
title: Fixes cabal new-build -> fix cabal new-build for cabal < 2.0
2017-08-16 18:41:56bfsetmessages: + msg19601
2017-08-16 18:43:40bfsetmessages: + msg19602
2017-10-12 16:44:52ghsetstatus: has-patch -> resolved
resolvedin: 2.14.0 HEAD