Issue 437 darcs hangs (ssh controlmaster)

Title darcs hangs (ssh controlmaster)
Priority not-our-bug Status resolved
Milestone Resolved in
Superseder Nosy List darcs-devel, dmitry.kurochkin, evilrob, kowey, luca, markstos, rgm, thorkilnaur, tommy, zooko
Assigned To
Topics SSH

Created on 2007-04-16.21:56:46 by evilrob, last changed 2009-10-24.00:07:45 by admin.

File name Uploaded Type Edit Remove
sshtester.pl kowey, 2007-10-23.21:50:21 text/plain
msg1603 (view) Author: evilrob Date: 2007-04-16.21:56:42
so I have a problem with darcs hanging indefinitely, giving no informative 
information about what's going on, and becoming unusable.

additionally, I've sent multiple mails about this, but apparently they're all 
getting lost (c.f. issue118 )
msg1604 (view) Author: evilrob Date: 2007-04-16.21:58:15
here's the mail(s) I'd previously sent.


Begin forwarded message:

From: Rob Kinninmont <>
Date: April 16, 2007 12:45:28 PM PDT
To: bugs@darcs.net
Subject: Fwd: gripe: hangs

So I was just chatting with my co-worker (zooko) again and he reports that this 
never made it to you guys - nor did it bounce.  very curious.

perhaps worth noting also, that I was getting similar behaviour when trying to 
from our central repo too.   (i.e. it 'just hangs', '-v -v -v -v' makes no 
and when I kill it, it reports '^Cdarcs: failed to read patch in get_extra:')

I'm currently rsyncing a whole copy of that repo down locally so that I can
try again with an all-local setup.  but this has blocked the merge I need to
do for over an hour now.

while I like many features of darcs, wasting time for hung operations, and/or
spending extra time dealing with exerimental work-arounds, all too frequently
grates severely on ones nerves...


p.s. I'm on an intel Mac, 10.4.9

Begin forwarded message:

From: Rob Kinninmont <>
Date: April 5, 2007 11:57:46 AM PDT
To: bugs@darcs.net
Subject: gripe: hangs

so for no readily identifiable reason, darcs has developed a habit of hanging.

I'll dispatch a 'push' from the command line, then it prints 'Pushing to 
and hangs.  sometimes it works. sometimes it takes a couple of tries (each time
waiting 5-10min doing something else before determining that it's dead) 

it's kinda frustrating.

  otto:~/trees/trunk/trunk robk$ dpush wol:trees/trunk
  Pushing to "wol:trees/trunk"...


  ^CwithSignalsHandled: Interrupted!

anyway, I just said "I wish darcs gave more informative messages about what it's 
so it was clearer what's failing when it hangs." to my co-worker, who said, 
"Send that
sentence to "bugs@darcs.net", please."

it's mostly the sense of impotence and beholdenness heaped upon the frustration 
having to deal with a wait-an-indeterminate-period-to-figure-out-whether-it's-
that causes the cursing...

I'm running
otto:~/trees/trunk/trunk robk$ darcs --version
1.0.8 (release)

msg1605 (view) Author: evilrob Date: 2007-04-16.22:01:22
and here's the results of retrying the pull.  set it going, left it for a while, 
went to lunch, came back, still hung.  even though it took a while to rsync the 
whole repo, this timeframe is far longer than any slow network link could 
account for (it's ~40 patches)

#[Mon Apr 16 12:55:22] otto:~/trees/trunk/trunk$ darcs pull -v -v -v -v dev:/

Pulling from "dev:/home/darcs/trunk"...
^Cdarcs: failed to read patch in get_extra:
Thu Apr  5 19:16:22 PDT 2007  warner@xxxxxxxxx.com
  * webfront: oops, RISystem.get_URI really does return an alternative, not a 
Perhaps this is a 'partial' repository?
#[Mon Apr 16 14:46:41] otto:~/trees/trunk/trunk$
msg1612 (view) Author: zooko Date: 2007-04-17.15:13:50
Rob: you're doing this on an Intel Mac, right?  I ask because all of my pulls on
my Intel Mac hang indefinitely, whereas pulling from the same repository on
Linux or Windows works.

Here's the version of darcs I'm using on my Intel Mac:
 wonwin-mcbrootles-computer:~$ darcs --exact-version
darcs compiled on Jun 24 2006, at 12:27:50
# configured Sat Jun 24 12:22:49 MST 2006
./configure --no-create --no-recursion


[TAG 1.0.8
Tommy Pettersson <ptp@lysator.liu.se>**20060616160213]
msg1613 (view) Author: kowey Date: 2007-04-17.15:38:24
Hi Rob,

Could you try this with --disable-ssh-cm?  You will have to use
ssh-agent in its place.  Something like
 eval `ssh-agent`
 darcs pull --disable-ssh-cm
 ssh-agent -k
msg1614 (view) Author: zooko Date: 2007-04-17.15:51:02
> Could you try this with --disable-ssh-cm?  You will have to use
> ssh-agent in its place.  Something like
>  eval `ssh-agent`
>  ssh-add
>  darcs pull --disable-ssh-cm
>  ssh-agent -k

I added "--disable-ssh-cm" to my cmd-line, and it fixed the problem.  I didn't
have to do the ssh-agent part because I have an unencrypted private key.


msg1615 (view) Author: evilrob Date: 2007-04-17.18:26:23
1. yes I'm on intel mac (as I said in my mail ;-)
I didn't know about 'exact-version' : 
#[Tue Apr 17 10:40:34] otto:~/trees/trunk/trunk$ darcs --exact-version
darcs compiled on Nov 14 2006, at 00:51:40
# configured Fri Jun 16 14:55:21 EDT 2006
./configure --no-create --no-recursion


[TAG 1.0.8
Tommy Pettersson <ptp@lysator.liu.se>**20060616160213] 

2. it worked this morning without problems (on one patch)
the next time I have trouble I'll definitely try it with --disable-ssh-cm
but I'll test it first without just in case it's in a happy mood today.
and I'm already using ssh-agent, so that's no problem.

I'll let you know after I'm done with today's work how it went ;-)

msg1616 (view) Author: evilrob Date: 2007-04-17.18:48:01
fwiw, it worked and pushed 119 patches without a hitch.

(without having to try --disable-ssh-cm)

but thanks for the suggestion - whenever I next hit problems (past experience 
suggests I won't have to wait _too_ long... ;-) I'll try that as a fix, and let 
you know how it goes.  

'til then,
msg1636 (view) Author: zooko Date: 2007-04-18.17:15:33
On Intel Mac, with darcs 1.0.9pre (exact version appended), push hangs, but
push --disable-ssh-cm works.



darcs compiled on Apr 17 2007, at 11:45:07
# configured Tue Apr 17 11:41:19 MDT 2007
./configure --prefix=/usr/local/stow/darcs-1.0.9pre


[Use LaTeX for ISO 8601 hyperlink.
Eric Kow <eric.kow@loria.fr>**20070217071601] 

[Documentation only: add link for ISO 8601 format
Kirsten Chevalier <chevalier@alum.wellesley.edu>**20070216004007

 In the documentation, make "ISO 8601 format" a link to the official
 W3C page describing the format (for those who don't know it by heart).

[fix bugs in replace.sh script--running wrong darcs.
David Roundy <droundy@darcs.net>**20070128001826] 

[add documentation for DARCS_PAGER
Benedikt Schmidt <beschmi@cloaked.de>**20070126142649] 

[Fix issue383 - allow --disable-ssh-cm for 'darcs changes'.
Georg Neis <gn@oglaroon.de>**20070121224417] 

[Canonize Marco TĂșlio Gontijo e Silva.
Eric Kow <eric.kow@loria.fr>**20070113231736

 Sorry for stripping off the accent.


[Redundant noncomments

 noncomments was already called by get_preffile via get_lines.

[Fix issue376 - inconsistent punctuation in darcs get.
Eric Kow <eric.kow@gmail.com>**20061231180024


[Fix issue367 - pull help message.
Eric Kow <eric.kow@gmail.com>**20061231174322] 

[fix some changelog entries
Tommy Pettersson <ptp@lysator.liu.se>**20061231210024] 

[allow commented tests in tests_to_run.
David Roundy <droundy@darcs.net>**20061211000322] 

[use variable TEST_FILTER_FILE in makefile.
David Roundy <droundy@darcs.net>**20061204151217] 

[add test target for testing hashed inventories.
David Roundy <droundy@darcs.net>**20060927020127] 

[update web page for new mailing list server.
David Roundy <droundy@darcs.net>**20070116162930] 

[fix spelling errors in comments
Benedikt Schmidt <beschmi@cloaked.de>**20061222020037] 

[Fix ssh.sh test.
Dave Love <fx@gnu.org>**20061218223442] 

[add warning about ALL and obliterate --all to documentation
Tommy Pettersson <ptp@lysator.liu.se>**20061219180302] 

[Fix includes in External.hs.
Dave Love <fx@gnu.org>**20061218224158
 You can't put comments before {-# INCLUDE ...

[add test for reverting removed directory
Tommy Pettersson <ptp@lysator.liu.se>**20061108202344] 

[Improve error messages in push_cmd

 I ran into this because MSYS was munging my repository directory in a
 horrible way. This resulted in a bad repo directory getting passed into
 darcs, which resulted in a fromJust error, which we all know makes the
 baby Jesus cry. So, I at least refactored the code to give a better
 error message, though there may well be a better solution.

[Implement prettyException.
Juliusz Chroboczek <jch@pps.jussieu.fr>**20061218025440] 

[Simplify common libcurl errors.
Juliusz Chroboczek <jch@pps.jussieu.fr>**20061218025419] 

[fix issue369 by failing if quickcheck isn't available
David Roundy <droundy@darcs.net>**20061218021545] 

[Don't QP-encode bundles when pushing locally.
Juliusz Chroboczek <jch@pps.jussieu.fr>**20061218002533] 

[Make darcs push QP-encode the bundle before transferring.
Juliusz Chroboczek <jch@pps.jussieu.fr>**20061217234635
 This should hopefully fix issues with scp/sftp corrupting bundles in transit.

[Adapt callers to new calling convention for make_email.
Juliusz Chroboczek <jch@pps.jussieu.fr>**20061217234608
 Use Just at the right places.

[Make arguments to make_email optional.
Juliusz Chroboczek <jch@pps.jussieu.fr>**20061217234501
 Makes contents and filename optional.  If they are omitted, we still
 generate a conforming MIME message.

[add test for get --tag and pending
Tommy Pettersson <ptp@lysator.liu.se>**20061211192821] 

[add new test related to issue262.
David Roundy <droundy@darcs.net>**20061217221041
 This issue seems to already have been fixed.

[Added test for reverting an unrecorded add

[add test that sigPIPE doesn't make darcs fail.
David Roundy <droundy@darcs.net>**20061209230155] 

[make it an error to "put" into a preexisting directory.
David Roundy <droundy@darcs.net>**20061203205826
 This changes darcs' behavior I believe for the better.  Often one could be
 tempted to try to put into a directory, expecting to have the repository
 created as a subdirectory there, and it seems confusing (confused me) to
 have instead the repository contents mingled with whatever was already in
 that directory.  Put should behave like get in this regard, in that it
 shouldn't mix the new repo with a preexisting directory.

[adapt test sametwice to new obliterate --all feature
Tommy Pettersson <ptp@lysator.liu.se>**20061130132058] 

[Adapt test perms.sh to obliterate --all feature.
Eric Kow <eric.kow@gmail.com>**20061209200625] 

[use impossible to document impossible case in Repair.
David Roundy <droundy@darcs.net>**20061204152854] 

[fix for Issue111, obliterate --all
David Roundy <droundy@darcs.net>**20061129164016
 This is a patch to implement the wishless item Issue111,
 which asks for an --all option to obliterate.  The idea is
 that you might use the --patches flag to select a bunch of
 patches and not want to have to say yess to all of them.

 For good measure, I also added it to unpull and unrecord.

[catch exceptions in stdout_is_a_pipe
Simon Marlow <simonmar@microsoft.com>**20061129160620] 

[hFlush after "waiting for lock" message
Simon Marlow <simonmar@microsoft.com>**20061129160342
 On Windows, stdout isn't always in line-buffered mode, but we really
 want to see the message about waiting for a lock quickly.  Mostly
 because ^C isn't always caught properly on Windows and lock files are
 often left behind, but that's another storey...


[add explicit import list
Simon Marlow <simonmar@microsoft.com>**20061129160144] 

[ignore failure from hSetBuffering
Tommy Pettersson <ptp@lysator.liu.se>**20061117221424
 This affects:
   issue41	Doesn't like pasted text.
   issue94	Crash on bogus input
   issue146	hSetBuffering: invalid argument
   issue318	buffering error of darcs record under bash/cmd.exe
 It doesn't necessarily "fix" anything. It prevents darcs from quiting,
 instead continuing with perhaps an undesirable buffering mode, which may or
 may not be better ... or worse.

[Hard link support on Windows
Simon Marlow <simonmar@microsoft.com>*-20061204162040
 This works only on NTFS filesystems.  Also it requires Windows 2000 or
 later; this may or may not be acceptable, I'll leave that up to the
 darcs maintainers to decide.

[Hard link support on Windows
Simon Marlow <simonmar@microsoft.com>**20061204162040
 This works only on NTFS filesystems.  Also it requires Windows 2000 or
 later; this may or may not be acceptable, I'll leave that up to the
 darcs maintainers to decide.

[Canonize Kirsten Chevalier.
Kirsten Chevalier <chevalier@alum.wellesley.edu>**20061217025004

 Added my name to the list of authors who originally only submitted an email


[Documentation only - clarify meaning of --from and --author
Kirsten Chevalier <chevalier@alum.wellesley.edu>**20061217024927

 Clarified the meaning of --from and --author. I had assumed that these
 options also set the From: address on the email sent by "darcs sent".  Of
 course they don't, but it's better to make this clear.


[Do _not_ allow escaped quotes in `quoted'.
Eric Kow <eric.kow@loria.fr>**20061030064531

 This undoes the patch by Dave Love: Allow escaped quotes in `quoted'.
 The immediate problem is that it breaks make_changelog (because one of
 Tommy's entries matches on a backslash).  This feature might need more
 discussion before we include it (or not).


[Replace tabs with spaces (escaped quotes in PatchMatch).
Eric Kow <eric.kow@loria.fr>**20061023192003] 

[Allow escaped quotes in `quoted'.
Dave Love <fx@gnu.org>**20060716193940] 

[Rename ssh_test to ssh.sh (for shell harness).
Eric Kow <eric.kow@gmail.com>**20061121141101

 Note that you must set environment variables for it do anything
 useful (namely REMOTE=you@someserver); something like the following
 should work:
   REMOTE=me@ make test

 You need to be using public key authentication to have a fully
 automated test.


[Overhaul and improve automation of ssh_test.
Eric Kow <eric.kow@gmail.com>**20061121141802

 * Now quits if you don't supply REMOTE; does not have any
   silly default values
 * Options now passed in through environment variables, so:
     NO_CONTROL_MASTER=1 REMOTE=me@ ./ssh_test
 * Performs some automated success checks (which means that
   it should be possible to use this from the harness if you
   have ssh-agent running)
 * Performs darcs send test
 * Does not try to pass darcs-ssh flags (like --disable-ssh-cm)
   to non-ssh-using commands like record


[Add a semi-automated test for SSH-related things.
Eric Kow <eric.kow@gmail.com>**20061110110801

 Testing SSH stuff is tricky in that (1) you need some place to connect
 to and (2) you often want to make sure that the user interactions work
 out right.  But it can't hurt to script away the boring stuff so that
 you are naturally encouraged to test things out more thoroughly.

[remove link to obsolete mirror of kernel repo.
David Roundy <droundy@darcs.net>**20061212012644] 

[Remove raw_mode functions from atomic_create.h.
Eric Kow <eric.kow@gmail.com>**20061008202738

 It seems these were once implemented in compat.c and have since been
 reimplemented in Haskell by Ian Lynagh on 2005-07-30.  These appear to
 just be leftover declarations in the C header.


[Add make rules for tags files.
Dave Love <fx@gnu.org>**20061113213923] 

[configure should fail if a required module isn't present.
David Roundy <droundy@darcs.net>**20061128024557] 

[look for --disable-ssh-cm in defaults files (issue351)
Tommy Pettersson <ptp@lysator.liu.se>**20061117180942] 

[Define infodepspatch locally in AmendRecord instead of exporting it from Patch


[Amending a patch doesn't remove explicit dependencies

[Make libcurl use any http authentication.
Tobias Gruetzmacher <darcs@portfolio16.de>**20061118230406
 This let darcs use repositories protected with digest authentication.

[Support darcs send --disable-ssh-cm.
Eric Kow <eric.kow@loria.fr>**20061121134158] 

[Redirect stderr to Null when exiting SSH control master.
Eric Kow <eric.kow@loria.fr>**20061118212115

 This suppresses the output
 * Pseudo-terminal will not be allocated because stdin is not a terminal.
   (result of redirecting stdin from /dev/null)
 * Exit request sent.
   (seems to be normal output. Seems also that there is no way to suppress
    this; -q does not do the job, for example)


[Fix curses stuff, especially on Solaris 10.
Dave Love <fx@gnu.org>**20061120171211] 

[Canonize Edwin Thomson.
Eric Kow <eric.kow@gmail.com>**20061118174454] 

[Annotate various boring patterns.
Dave Love <fx@gnu.org>**20061113225701] 

[TAG 1.0.9rc2
Tommy Pettersson <ptp@lysator.liu.se>**20061116140351]
msg1637 (view) Author: kowey Date: 2007-04-18.17:51:26
Note that the more recent unstable disables ssh cm by default.  The flags have
now been renamed to --ssh-cm and --no-ssh-cm for consistency.

It's a bug we hope to fix.  I just don't know how yet.
msg2147 (view) Author: droundy Date: 2007-09-27.14:13:36
On Thu, Sep 27, 2007 at 12:24:52AM +0200, Luca Capello wrote:
> Hello David!


> > The bug is hard to reproduce (in our experience), and has been
> > difficult to track down.
> Unfortunately, I forgot to note down that this happens *regularly*
> every time I use it, so it's reproducible at least on my box.  So, how
> can I debug it?

But alas, we don't yet know how to produce it regularly on anyone else's
box.  :(

I'm not sure how you'd debug it.  Perhaps using strace? This is a bit of
the code I'm not very familiar with, so I'm not likely to be of much use
here.  I'm ccing our bug tracker, so Eric will be in contact.  Apparently
the bug is also reproducible on Intel macs, for whatever reason.

> However, if I start an ssh session (obviously with ControlMaster
> enabled) on another xterm before launching the darcs command without
> the --ssh-cm option, darcs picks up that ssh session and it doesn't
> ask for any password.  With the --ssh-cm option, it tries to manage
> the ssh connection even if another one is already established.

And I presume that in this case darcs freezes? I'm not sure how we'd
determine whether a connection is already made, and suspect that the only
correct behavior when --ssh-cm is specified is to try to start one

P.S. If you keep the subject fixed, it'll help keep our bug tracker
David Roundy
Department of Physics
Oregon State University
msg2171 (view) Author: kowey Date: 2007-10-21.21:59:34
Please see
for a Haskell script that we can use to help debug this.  If people want to hack
on this, it may even be worth setting up another public branch for it.
msg2172 (view) Author: kowey Date: 2007-10-23.21:50:21
Following a wonderfully simple suggestion by Petr Rockai and Alexander Staubo, I
have reproduced the SSH hanging without darcs or Haskell for that matter. 
Attached is a Perl script that does the hanging thing.

Filed a report on the OpenSSH bugzilla:
msg2863 (view) Author: kowey Date: 2008-01-29.15:54:53
Would the new transfer-mode patches make use of controlmaster moot?  (It would b
e really nice if it did!)
msg2867 (view) Author: droundy Date: 2008-01-29.16:10:40
On Tue, Jan 29, 2008 at 03:54:56PM -0000, Eric Kow wrote:
> Would the new transfer-mode patches make use of controlmaster moot?  (It
> would b e really nice if it did!)

It will *almost* make controlmaster moot.  The new transfer-mode requires
that a sufficiently recent darcs be present (and in the path) on the
server, which is currently not required for read-only access using
controlmaster over ssh.  The second issue is that transfer-mode doesn't
affect the call to darcs apply when pushing or putting.  So with
transfer-mode, push and put will make two connections (actually, three in
the case of put, one needed to initialize the repo), where controlmaster
requires only one.  On the other hand, given the pain we've had with
controlmaster, maybe this isn't much of a drawback.  We could potentially
add functionality to transfer-mode to enable running darcs over this
connection, but I'd rather not, as it'd greatly increase the complexity and
probability of bugs.  I don't think it's unreasonable to make an extra
connection when modifying the repository.
David Roundy
Department of Physics
Oregon State University
msg3306 (view) Author: markstos Date: 2008-02-11.01:21:13
So we can consider Controlmaster issues "resolved in unstable" with thie
disclaimer that you have run recent darcs builds on both ends for the problem to
go away? 

The comment about making two or three connections instead of one didn't seem
like a big deal to me, especially compared the old system of making N connections.
msg3325 (view) Author: droundy Date: 2008-02-11.16:59:05
On Mon, Feb 11, 2008 at 01:21:14AM -0000, Mark Stosberg wrote:
> So we can consider Controlmaster issues "resolved in unstable" with thie
> disclaimer that you have run recent darcs builds on both ends for the problem to
> go away? 

I think that's reasonable.  I don't think we should *remove* controlmaster,
but given that it's not the default and there are reasonable alternatives,
there's no need to consider it a "real" bug any more (particularly as I
think we've established that it was never *our* bug).
David Roundy
Department of Physics
Oregon State University
Date User Action Args
2007-04-16 21:56:46evilrobcreate
2007-04-16 21:58:18evilrobsetstatus: unread -> unknown
nosy: droundy, tommy, beschmi, kowey, zooko, evilrob
messages: + msg1604
2007-04-16 22:01:25evilrobsetnosy: droundy, tommy, beschmi, kowey, zooko, evilrob
messages: + msg1605
2007-04-17 15:13:59zookosetnosy: droundy, tommy, beschmi, kowey, zooko, evilrob
messages: + msg1612
2007-04-17 15:38:32koweysetnosy: droundy, tommy, beschmi, kowey, zooko, evilrob
messages: + msg1613
2007-04-17 15:51:10zookosetnosy: droundy, tommy, beschmi, kowey, zooko, evilrob
messages: + msg1614
2007-04-17 18:26:33evilrobsetnosy: droundy, tommy, beschmi, kowey, zooko, evilrob
messages: + msg1615
2007-04-17 18:48:02evilrobsetnosy: droundy, tommy, beschmi, kowey, zooko, evilrob
messages: + msg1616
2007-04-17 23:21:45evilrobsetnosy: droundy, tommy, beschmi, kowey, zooko, evilrob
superseder: + gripe: hangs
2007-04-18 17:15:52zookosetnosy: droundy, tommy, beschmi, kowey, zooko, evilrob
messages: + msg1636
2007-04-18 17:51:43koweysettopic: + SSH
nosy: + rgm
messages: + msg1637
title: darcs hangs -> darcs hangs (ssh controlmaster)
2007-08-01 07:10:15koweysetnosy: droundy, tommy, beschmi, kowey, zooko, rgm, evilrob
superseder: - gripe: hangs
2007-09-27 14:13:37droundysetnosy: + 444057, luca
messages: + msg2147
2007-10-21 21:59:35koweysetnosy: - 444057
messages: + msg2171
2007-10-23 21:50:22koweysetfiles: + sshtester.pl
messages: + msg2172
2007-10-23 21:51:09koweysetpriority: bug -> not-our-bug
2008-01-29 15:54:56koweysetnosy: droundy, tommy, beschmi, kowey, zooko, rgm, evilrob, luca
messages: + msg2863
2008-01-29 16:10:42droundysetnosy: droundy, tommy, beschmi, kowey, zooko, rgm, evilrob, luca
messages: + msg2867
2008-02-11 01:21:14markstossetnosy: + markstos
messages: + msg3306
2008-02-11 16:59:06droundysetnosy: droundy, tommy, beschmi, kowey, markstos, zooko, rgm, evilrob, luca
messages: + msg3325
2008-02-12 00:00:13markstossetstatus: unknown -> resolved-in-unstable
nosy: droundy, tommy, beschmi, kowey, markstos, zooko, rgm, evilrob, luca
2008-09-04 21:30:51adminsetstatus: resolved-in-unstable -> resolved
nosy: + dagit
2009-08-06 17:34:48adminsetnosy: + jast, Serware, dmitry.kurochkin, darcs-devel, mornfall, simon, thorkilnaur, - droundy, rgm, evilrob, luca
2009-08-06 20:32:03adminsetnosy: - beschmi
2009-08-10 22:03:05adminsetnosy: + rgm, luca, evilrob, - darcs-devel, jast, Serware, mornfall
2009-08-11 00:00:14adminsetnosy: - dagit
2009-08-25 17:49:16adminsetnosy: + darcs-devel, - simon
2009-08-27 14:06:37adminsetnosy: tommy, kowey, markstos, darcs-devel, zooko, rgm, evilrob, thorkilnaur, luca, dmitry.kurochkin
2009-10-23 22:41:56adminsetnosy: + robmoss, - rgm
2009-10-24 00:07:45adminsetnosy: + rgm, - robmoss