darcs

Patch 1605 make DARCS_DONT_ESCAPE_8BIT=1 the default (and 1 more)

Title make DARCS_DONT_ESCAPE_8BIT=1 the default (and 1 more)
Superseder Nosy List bf
Related Issues
Status accepted Assigned To
Milestone

Created on 2017-10-02.17:51:49 by bf, last changed 2017-10-26.13:29:10 by gh.

Files
File name Status Uploaded Type Edit Remove
make-darcs_dont_escape_8bit_1-the-default.dpatch bf, 2017-10-02.17:51:49 application/x-darcs-patch
See mailing list archives for discussion on individual patches.
Messages
msg19684 (view) Author: bf Date: 2017-10-02.17:51:49
See my message to @darcs-users
https://lists.osuosl.org/pipermail/darcs-users/2017-September/027245.html

I am not yet screening it as it might be controversial. But I am
strongly in favour of making this move. The other patch only
accidentally depends on the first, it makes sense without the first
patch but would need to be rebased.

2 patches for repository http://darcs.net/screened:

patch a847b6852c2434e56d55cd709d4bf28380ddc4ea
Author: Ben Franksen <ben.franksen@online.de>
Date:   Wed Sep 27 18:25:29 CEST 2017
  * make DARCS_DONT_ESCAPE_8BIT=1 the default
  
  More precisely, we no longer recognize this environment variable, instead
  can set DARCS_ESCAPE_8BIT to 1 if so desired. Also re-wrote most of
the help
  text for this and other environment variables related to character
escaping.

patch 1c9ec8fb924e8214f911f23919805c910bd0ea71
Author: Ben Franksen <benjamin.franksen@helmholtz-berlin.de>
Date:   Wed Sep 27 18:28:53 CEST 2017
  * fix failing test for issue2480
  
  It tested encoding of meta data, not patch content.
Attachments
History
Date User Action Args
2017-10-02 17:51:49bfcreate
2017-10-10 14:07:54ghsetstatus: needs-screening -> needs-review
2017-10-26 13:29:10ghsetstatus: needs-review -> accepted