darcs

Patch 1819 issue2257 fails only for darcs-2 repos a... (and 1 more)

Title issue2257 fails only for darcs-2 repos a... (and 1 more)
Superseder Nosy List bf
Related Issues
Status needs-review Assigned To
Milestone

Created on 2019-06-13.11:42:56 by bf, last changed 2019-06-15.08:10:28 by bf.

Files
File name Status Uploaded Type Edit Remove
issue2257-fails-only-for-darcs_2-repos-and-that-will-never-be-fixed.dpatch bf, 2019-06-13.11:42:56 application/x-darcs-patch
patch-preview.txt bf, 2019-06-13.11:42:56 text/x-darcs-patch
unnamed bf, 2019-06-13.11:42:56 text/plain
See mailing list archives for discussion on individual patches.
Messages
msg20772 (view) Author: bf Date: 2019-06-13.11:42:56
Following up on screening the V3 bundle, I am declaring some tests as
succeeding and just skip them for the formats they still fail with.

2 patches for repository http://darcs.net/screened:

patch b67f24e6d75014d3a6950daf292690084fc7e796
Author: Ben Franksen <ben.franksen@online.de>
Date:   Wed Jun 12 18:54:59 CEST 2019
  * issue2257 fails only for darcs-2 repos and that will never be fixed

patch 1ce1846d0130a0901bf02cf663546234a8aba133
Author: Ben Franksen <ben.franksen@online.de>
Date:   Wed Jun 12 19:19:18 CEST 2019
  * issue1401 and issue2605 no longer fail, at least for darcs-3
  
  They are both instances of the same underlying problem in darcs-1 and
  darcs-2 patches, namely that they cannot distinguish between duplicate prim
  patches. The darcs-3 format allows that and thus does not fail these tests.
Attachments
msg20813 (view) Author: ganesh Date: 2019-06-15.07:16:02
I'm fine with these being screened (I can double-check if they 
pass for me when reviewing).
History
Date User Action Args
2019-06-13 11:42:56bfcreate
2019-06-15 07:16:02ganeshsetmessages: + msg20813
2019-06-15 08:10:28bfsetstatus: needs-screening -> needs-review