darcs

Patch 1933 add setup-depends upper bound for Cabal

Title add setup-depends upper bound for Cabal
Superseder Nosy List ganesh
Related Issues
Status accepted Assigned To
Milestone

Created on 2019-09-22.20:29:15 by ganesh, last changed 2019-09-26.10:32:17 by bf.

Files
File name Status Uploaded Type Edit Remove
add-setup_depends-upper-bound-for-cabal.dpatch ganesh, 2019-09-22.20:29:15 application/x-darcs-patch
patch-preview.txt ganesh, 2019-09-22.20:29:15 text/x-darcs-patch
unnamed ganesh, 2019-09-22.20:29:15 text/plain
See mailing list archives for discussion on individual patches.
Messages
msg21536 (view) Author: ganesh Date: 2019-09-22.20:29:15
The urgency of simplifying our cabal setup increases..

1 patch for repository darcs-unstable@darcs.net:screened:

patch 96163dcbd89f2a89ccd7c8d4f74a27b12f7abbc5
Author: Ganesh Sittampalam <ganesh@earth.li>
Date:   Sun Sep 22 20:53:37 BST 2019
  * add setup-depends upper bound for Cabal
  
  sDistHook has been removed in Cabal 3.0
Attachments
msg21600 (view) Author: ganesh Date: 2019-09-25.20:00:01
I'm going to push this to reviewed now because otherwise it's a pain
running the tests to push other things to reviewed.
msg21604 (view) Author: bf Date: 2019-09-26.10:32:17
> I'm going to push this to reviewed now because otherwise it's a pain
> running the tests to push other things to reviewed.

Yes, fine with me. I am having a bit of trouble keeping up with review
of your patches because I want to follow up on the points you raised
when you reviewed mine.
History
Date User Action Args
2019-09-22 20:29:15ganeshcreate
2019-09-22 20:29:28ganeshsetstatus: needs-screening -> needs-review
2019-09-25 20:00:01ganeshsetstatus: needs-review -> accepted-pending-tests
messages: + msg21600
2019-09-25 21:05:09ganeshsetstatus: accepted-pending-tests -> accepted
2019-09-26 10:32:17bfsetmessages: + msg21604