darcs

Patch 2149 globally rename readRecorded to readPris... (and 3 more)

Title globally rename readRecorded to readPris... (and 3 more)
Superseder Nosy List bf
Related Issues
Status accepted Assigned To
Milestone

Created on 2021-01-10.18:17:27 by bf, last changed 2021-04-03.19:31:26 by ganesh.

Files
File name Status Uploaded Type Edit Remove
globally-rename-readrecorded-to-readpristine.dpatch bf, 2021-01-10.18:17:26 application/x-darcs-patch
patch-preview.txt bf, 2021-01-10.18:17:26 text/x-darcs-patch
unnamed bf, 2021-01-10.18:17:26 text/plain
See mailing list archives for discussion on individual patches.
Messages
msg22621 (view) Author: bf Date: 2021-01-10.18:17:26
This is what I proposed in msg22595 plus a few related renamings and a minor
refactor that removes the asymmetry between readPatches and
readTentativePatches.

4 patches for repository http://darcs.net/screened:

patch 256044b1816aa269e12ecea339f47b69f6a62cbf
Author: Ben Franksen <ben.franksen@online.de>
Date:   Tue Dec 22 11:24:07 CET 2020
  * globally rename readRecorded to readPristine
  
  Also rename readRecordedAndPending to readPristineAndPending.

patch cf0b06c0a8529bb81591c3bee0f4c9d462219f6b
Author: Ben Franksen <ben.franksen@online.de>
Date:   Tue Dec 22 12:08:17 CET 2020
  * rename readRepo->readPatches, readTentativeRepo->readTentativePatches
  
  readRepoHashed is only used internally and no longer exported. This and
  other procedures internal to Darcs.Repository.Hashed will be renamed in
  another patch.

patch 880c1e33c20c1da5c3649fabaca073dfe10d5eb9
Author: Ben Franksen <ben.franksen@online.de>
Date:   Tue Dec 22 14:29:49 CET 2020
  * remove the extra repo directory parameter from readTentativePatches and others
  
  Instead we now always use repoLocation for that. The other procedures are
  readRepoUsingSpecificInventory and readRepoHashed. This effectively changes
  only two internal calls in D.R.Hashed, one in finalizeTentativeChanges and
  one in removeFromTentativeInventory where we passed "." instead.

patch eff4a5e944e75566734a3e8ed5e05251faf7e347
Author: Ben Franksen <ben.franksen@online.de>
Date:   Tue Dec 22 14:55:48 CET 2020
  * internal renames in D.R.Hashed (readRepo...->readPatches... + some more)
Attachments
msg22690 (view) Author: ganesh Date: 2021-03-28.13:46:18
All fine
History
Date User Action Args
2021-01-10 18:17:27bfcreate
2021-01-10 18:17:49bfsetstatus: needs-screening -> needs-review
2021-03-28 13:46:18ganeshsetstatus: needs-review -> accepted-pending-tests
messages: + msg22690
2021-04-03 19:31:26ganeshsetstatus: accepted-pending-tests -> accepted