Patch 2222 rename addPendingDiffToPending to unsafe... (and 1 more)

Title rename addPendingDiffToPending to unsafe... (and 1 more)
Superseder Nosy List bf
Related Issues
Status needs-review Assigned To

Created on 2021-11-06.00:52:56 by bf, last changed 2021-11-06.00:53:17 by bf.

File name Status Uploaded Type Edit Remove
patch-preview.txt bf, 2021-11-06.00:52:54 text/x-darcs-patch
rename-addpendingdifftopending-to-unsafeaddtopending.dpatch bf, 2021-11-06.00:52:54 application/x-darcs-patch
See mailing list archives for discussion on individual patches.
msg22925 (view) Author: bf Date: 2021-11-06.00:52:54
2 patches for repository http://darcs.net/screened:

patch 2831f357496865c76860dc9438f195dcb8b13fec
Author: Ben Franksen <ben.franksen@online.de>
Date:   Tue Mar  2 14:26:11 CET 2021
  * rename addPendingDiffToPending to unsafeAddToPending

patch 8237940978023934f829ef3d5d449007b867d55f
Author: Ben Franksen <ben.franksen@online.de>
Date:   Tue Mar  2 16:06:25 CET 2021
  * remove the unsafe tentativelyAddToPending, replace with addToPending

  The fact that this type checks witnesses the fact that indeed using
  tentativelyAddToPending was wrong: the patches we pass all start at the
  unrecorded state and thus should be commuted past the difference between
  pending and working before appending them to pending. This is what
  addToPending does which is why it is the safer choice here.
Date User Action Args
2021-11-06 00:52:56bfcreate
2021-11-06 00:53:17bfsetstatus: needs-screening -> needs-review