Issue 2505 darcs needs to be updated for sandi 0.4+ to be in stackage nightly

Title darcs needs to be updated for sandi 0.4+ to be in stackage nightly
Priority Status resolved
Milestone Resolved in 2.12.0
Superseder Nosy List simon
Assigned To

Created on 2016-08-30.00:16:54 by simon, last changed 2016-09-04.13:30:42 by gh.

msg19238 (view) Author: simon Date: 2016-08-30.00:16:53
darcs has been disabled in the current stackage nightly due to not supporting the newer sandi that is required 
with GHC 8. See https://github.com/fpco/stackage/issues/1399#issuecomment-242946911 .

darcs is still in the current lts snapshot (lts-6.14), but the nightly will become the new lts before too much 
longer (and will then be the one used by default for users doing "stack install darcs").

Moving to or adding support for sandi 0.4 will also make it easier (possible ?) to build darcs with GHC 8.
msg19240 (view) Author: ganesh Date: 2016-08-30.02:34:17
Couple of notes on the current status of this:

- sandi 0.4 is API incompatible with sandi 0.3, so darcs will either 
need to just support sandi 0.4, or use CPP
- sandi 0.4 doesn't support GHC 7.6, which darcs 2.12.x does support 
(HEAD/darcs 2.13 will probably drop this support, but I'm not sure 
it's appropriate for a release branch)

- sandi 0.3.6 does work ok with GHC 8 if you use --allow-newer, so 
darcs does currently build with GHC 8.0 if you use --allow-newer --
constraint 'sandi<0.4' (I only tested HEAD but I think 2.12 is the 
msg19256 (view) Author: gh Date: 2016-09-04.13:30:40
This has been fixed by Sergei's patch in HEAD and bracn 2.12.
Date User Action Args
2016-08-30 00:16:55simoncreate
2016-08-30 02:34:18ganeshsetmessages: + msg19240
2016-09-04 13:30:42ghsetstatus: unknown -> resolved
messages: + msg19256
resolvedin: 2.12.0