Issue 454 darcs + scp doesn't work for paths with whitespace

Title darcs + scp doesn't work for paths with whitespace
Priority bug Status needs-reproduction
Milestone Resolved in
Superseder Nosy List darcs-devel, dmitry.kurochkin, giksos, kowey, markstos, mihai, rgm, thorkilnaur, tommy
Assigned To
Topics SSH

Created on 2007-05-10.02:43:50 by giksos, last changed 2011-10-17.18:16:36 by mihai.

msg1680 (view) Author: giksos Date: 2007-05-10.02:43:41
Here is the problem:

:~/tmp/darcs> mkdir two\ words
:~/tmp/darcs> cd two\ words/
:~/tmp/darcs/two words> darcs init
:~/tmp/darcs/two words> cd ..
:~/tmp/darcs> darcs get "localhost:tmp/darcs/two words"
Invalid repository:  localhost:tmp/darcs/two words

darcs failed:  (scp) failed to fetch: localhost:tmp/darcs/two words/_darcs/inventory

Here is how I solved it for myself (a darcs patch):

hunk ./External.hs 188
+                 tr ' ' = "\\ "

I imagine that copySSHs might also need some change.
msg1686 (view) Author: kowey Date: 2007-05-10.18:09:52
Any chance you could darcs send a patch to

(I'd say stable, as this seems innocuous enough a fix)
msg1690 (view) Author: giksos Date: 2007-05-12.00:10:37
ok, did it. Though I can't be quite sure that it is correct or that it is enough :)
msg1692 (view) Author: kowey Date: 2007-05-12.19:40:49

On Sat, May 12, 2007 at 00:10:41 +0000, Misha Aizatulin wrote:
> ok, did it. Though I can't be quite sure that it is correct or that it is enough :)

For what it's worth, I haven't received anything from the mailing list.
Could you double-check?  The darcs send should result in a mail to the
darcs-devel@darcs.net list

Or if that doesn't work, maybe attach a darcs patch to the tracker by
sending it as an attachment.

Sorry to make you jump through hoops!  Just think of it as your first
contribution to the darcs community (pending review, of course).
msg1707 (view) Author: giksos Date: 2007-05-24.01:02:57
well, I guess the problem was that my postfix wasn't set up and running :) I
tried it once more, hope it arrives now.
msg1817 (view) Author: kowey Date: 2007-07-12.20:49:41
Just wanted to note that we had applied this patch in stable, but then decided
to roll it back, because it wasn't worth the risk.  

I'd recommend that a revised patch which covers both the scp and sftp be submitted.

See message <20070530191915.GB217@dewdrop.local> on darcs-devel, or
msg3276 (view) Author: markstos Date: 2008-02-09.18:54:27
It sounds like there is still uncertainty here about why this fails and if is
something we should even be addressing or whether it is "not-our-bug".
msg4414 (view) Author: kowey Date: 2008-04-30.19:45:56
There was a patch for this, but it only handled the case for scp.  This seems
like it's worth fixing.  We just need the sftp case covered as well.
msg8672 (view) Author: kowey Date: 2009-09-04.08:43:58
First: We need somebody to test if darcs transfer-mode suffers from the same
problem and to write a regression test.

Second: We need somebody to revisit Misha's patch and re-do it for scp and sftp
both.  It'll probably only matter for the case where the remote end does not
have a darcs 2 client.

Thu May 24 01:42:32 CEST 2007  Misha Aizatulin <avatar@hot.ee>
  * fix scp whitespace
msg14776 (view) Author: mihai Date: 2011-10-17.17:54:50
The problem still exists in 2.5.2:

$ darcs push --remote-darcs=/user/mihai/bin/darcs
'--remote-repo=remotemachine:projects/app\ f/trunk' 
Pushing to "remotemachine:projects/app\\ f/trunk"...
Mon Oct 17 13:37:43 EDT 2011  mihai@...
  * Entered a random change to test darcs.
Shall I push this patch? (1/1)  [ynW...], or ? for more options: y

darcs failed:  can't set directory to projects/app\ f/trunk
Apply failed!

Both the local and the remote darcs binaries are at version 2.5.2 (release).
msg14777 (view) Author: markstos Date: 2011-10-17.18:04:36
Thanks for the follow-up. What OS and shell versions were involved in
your test?

msg14778 (view) Author: mihai Date: 2011-10-17.18:16:35
Remote machine:
Red Hat Enterprise Linux Server release 5.3 x86_64
GNU bash 3.2.25

Local machine:
Ubuntu 11.04 x86_64
GNU bash 4.2.8
Date User Action Args
2007-05-10 02:43:50giksoscreate
2007-05-10 18:09:54koweysetstatus: unread -> unknown
nosy: droundy, tommy, beschmi, kowey, giksos
messages: + msg1686
2007-05-12 00:10:41giksossetnosy: droundy, tommy, beschmi, kowey, giksos
messages: + msg1690
2007-05-12 19:40:58koweysetnosy: droundy, tommy, beschmi, kowey, giksos
messages: + msg1692
2007-05-24 01:03:08giksossetnosy: droundy, tommy, beschmi, kowey, giksos
messages: + msg1707
2007-07-12 20:49:42koweysetnosy: droundy, tommy, beschmi, kowey, giksos
messages: + msg1817
2007-07-23 20:57:54koweysettopic: + SSH
nosy: + rgm
2008-02-09 18:54:28markstossetstatus: unknown -> deferred
nosy: + markstos
messages: + msg3276
2008-04-30 19:45:57koweysetstatus: deferred -> unknown
nosy: + dagit
messages: + msg4414
2008-05-14 08:34:04koweysetstatus: unknown -> has-patch
nosy: droundy, tommy, beschmi, kowey, markstos, dagit, rgm, giksos
2009-08-06 17:44:22adminsetnosy: + jast, Serware, dmitry.kurochkin, darcs-devel, zooko, mornfall, simon, thorkilnaur, - droundy, rgm, giksos
2009-08-06 20:40:59adminsetnosy: - beschmi
2009-08-10 22:04:03adminsetnosy: + rgm, giksos, - darcs-devel, zooko, jast, Serware, mornfall
2009-08-11 00:00:27adminsetnosy: - dagit
2009-08-25 17:57:10adminsetnosy: + darcs-devel, - simon
2009-08-27 13:58:49adminsetnosy: tommy, kowey, markstos, darcs-devel, rgm, giksos, thorkilnaur, dmitry.kurochkin
2009-09-04 08:44:00koweysetstatus: has-patch -> needs-reproduction
nosy: tommy, kowey, markstos, darcs-devel, rgm, giksos, thorkilnaur, dmitry.kurochkin
messages: + msg8672
2009-10-23 22:41:58adminsetnosy: + robmoss, - rgm
2009-10-24 00:07:47adminsetnosy: + rgm, - robmoss
2011-10-17 17:28:28mihaisetnosy: + mihai
2011-10-17 17:54:51mihaisetmessages: + msg14776
2011-10-17 18:04:36markstossetmessages: + msg14777
2011-10-17 18:16:36mihaisetmessages: + msg14778