> A common theme here is to move stuff that has nothing to do with Repository
> mechanics, namely running hooks and tests, from the Repository to the UI
> layer, especially since running hooks may involve prompting the user.
I see why it doesn't belong in the Repository layer, but the UI layer
also feels a bit wrong. Maybe this class of things does justify a new
layer? One idea off the top of my head would be "Action", so
functionality like hooks and tests could live in Darcs.Action.Hook and
Darcs.Action.Test respectively.
> * bugfix: --leave-test-dir should be off by default
> * support --leave-test-dir for all commands that support --test
OK
> * refactor testing of the tentative pristine
OK
> * inline runTest into getTest and move to UI layer
OK
> * move remainder of D.R.Test to D.UI.RunHook
OK
> * reduce code duplication in Darcs.UI.RunHook
OK
> * move Hook(s)Config from D.R.Flags to D.UI.Options.All
OK
> * use promptYorn when asking whether to execute hook
OK
|