Hi,
I'm not going to self-screen this immediately (apart from the issue1988
cleanup), because I'd like some feedback on whether the change is a good
thing.
The basic idea is to make it easier to have repository operations
that aren't polymorphic on every kind of patch type. This need
comes up in the existing code, where for example convert currently
hacks around it with unsafeCoerce; and it's also something I want for
rebase.
So instead of the $- operator, callers of withRepoLock etc pass
in a "job". The old kind of polymorphic job is a "RepoJob", but
I then go on to add V1Job and V2Job to deal with what convert needs.
Cheers,
Ganesh
4 patches for repository http://darcs.net/screened:
Mon Dec 13 18:51:11 GMT 2010 Ganesh Sittampalam <ganesh@earth.li>
* get rid of the ($-) operator
Wrap up the Rank2 types of the repository handling operations in a
datatype rather than requiring the specialised ($-). This helps with a
planned change to add more functionality to these operations.
Mon Dec 13 19:02:59 GMT 2010 Ganesh Sittampalam <ganesh@earth.li>
* generic job transformation function
Mon Dec 13 19:13:54 GMT 2010 Ganesh Sittampalam <ganesh@earth.li>
* issue1988 cleanup: accept warning
Tue Dec 21 19:22:15 GMT 2010 Ganesh Sittampalam <ganesh@earth.li>
* add new types of repository job to clean up Convert a bit
Still not pretty, but at least the unsafeCoerce# is further down!
Attachments
|