Issue 1050 failure in tests/{obliterate,unpull}.pl

Title failure in tests/{obliterate,unpull}.pl
Priority bug Status resolved
Milestone 2.1.x Resolved in
Superseder Nosy List E.Y.Kow, darcs-devel, dmitry.kurochkin, glehmann, kowey, thorkilnaur, zooko
Assigned To
Topics Regression

Created on 2008-08-31.12:12:00 by kowey, last changed 2010-06-15.21:48:21 by admin.

msg5834 (view) Author: kowey Date: 2008-08-31.12:11:54
The test in question checks that obliterate gives you the "Really obliterate"
prompt when you answer 'a' to a patch.  This test appears to work when you do it
by hand, but somehow darcs's output is cut off if you feed it in automatically
via echo_to_darcs

You can check this by doing
cd tests
DARCS_KEEP_TEMPDIR=1 perl bin/prove obliterate.pl
msg5835 (view) Author: kowey Date: 2008-08-31.12:41:10
Ahah... two details:

If I do darcs obliterate | tee /tmp/foo

I get
darcs: getTerminalAttributes: illegal operation (Inappropriate ioctl for device)

And if I compile with --disable-haskeline, the test passes
msg5839 (view) Author: zooko Date: 2008-08-31.15:56:34
What is haskeline?  Can we disable it by default?
msg5840 (view) Author: kowey Date: 2008-08-31.16:01:37
Haskeline is a sort of Haskell readline:

Its use is only triggered when the library is installed; otherwise, darcs goes
back to what it always did.

Hmm, maybe that doesn't explain the recent buildbot failures then.

You can configure --disable-haskeline if it helps.
msg5848 (view) Author: glehmann Date: 2008-08-31.19:54:06
It seems to be a bug in haskeline. I'm sending a bug report to the author, with
a test case and a link to this bug.
In the mean time, haskeline should be turned off by default.
msg5852 (view) Author: glehmann Date: 2008-08-31.20:49:39
ticket submitted to haskeline trac's!
msg5857 (view) Author: kowey Date: 2008-09-01.09:31:47
On Sun, Aug 31, 2008 at 20:49:41 -0000, Gaƫtan Lehmann wrote:
> ticket submitted to haskeline trac's!
> http://trac.haskell.org/haskeline/ticket/31

Thanks!  (I especially like how you cooked up a minimal test case for
the Haskelline folks or maybe just Judah)  

In the meantime, do you think we should disable haskeline by default
i.e. create an --enable-haskeline flag?  If so, maybe you could submit
a patch.

I guess the only people that are affected are
 - people running the test suite (we have --disable-haskeline)
 - people who try to pipe stdout
msg5918 (view) Author: E.Y.Kow Date: 2008-09-05.14:24:36
The following patch updated the status of issue1050 to be resolved:

* Resolve issue1050: Disable haskeline by default. 
We should revisit this when the Haskeline bug in question is fixed.
msg5987 (view) Author: glehmann Date: 2008-09-12.08:41:30
The bug is now fixed in haskeline. I asked the author when he plan to release
the new haskeline version - if that's not so far, it should be possible to turn
that feature on by default in the next release.
Date User Action Args
2008-08-31 12:12:01koweycreate
2008-08-31 12:41:12koweysetstatus: unread -> unknown
messages: + msg5835
2008-08-31 15:56:36zookosetmessages: + msg5839
2008-08-31 16:01:39koweysetmessages: + msg5840
2008-08-31 19:54:08glehmannsetnosy: + glehmann
messages: + msg5848
2008-08-31 20:49:41glehmannsetmessages: + msg5852
2008-09-01 09:31:50koweysetmessages: + msg5857
2008-09-05 14:24:38E.Y.Kowsetstatus: unknown -> resolved-in-unstable
nosy: + E.Y.Kow
messages: + msg5918
2008-09-12 08:41:32glehmannsetnosy: kowey, zooko, dagit, E.Y.Kow, glehmann
messages: + msg5987
2009-04-22 03:34:10twbsetstatus: resolved-in-unstable -> resolved
nosy: + dmitry.kurochkin, simon, thorkilnaur
2009-08-06 18:23:17adminsetnosy: + tommy, beschmi, - zooko, E.Y.Kow, glehmann
2009-08-06 21:12:15adminsetnosy: - beschmi
2009-08-10 21:48:09adminsetnosy: + E.Y.Kow, glehmann, zooko, - tommy
2009-08-10 23:44:33adminsetnosy: - dagit
2009-08-25 17:44:30adminsetnosy: + darcs-devel, - simon
2009-08-27 14:19:03adminsetnosy: kowey, darcs-devel, zooko, thorkilnaur, dmitry.kurochkin, E.Y.Kow, glehmann
2010-06-15 21:48:20adminsetmilestone: 2.1.x
2010-06-15 21:48:21adminsettopic: - Target-2.1