darcs

Issue 1105 defaults file silently rejects abbreviations

Title defaults file silently rejects abbreviations
Priority bug Status resolved
Milestone Resolved in
Superseder Nosy List darcs-devel, dmitry.kurochkin, jaredj, kowey, mornfall, thorkilnaur
Assigned To
Topics ProbablyEasy, UI

Created on 2008-09-27.09:04:49 by kowey, last changed 2009-08-27.14:19:22 by admin.

Messages
msg6145 (view) Author: kowey Date: 2008-09-27.09:04:44
This is a UI gotcha that we really ought to fix.  It should either accept
abbreviations or tell the user it doesn't like them (maybe as a warning). 
Adding Dmitry because I think he might know how to fix it :-)
msg6196 (view) Author: dmitry.kurochkin Date: 2008-10-01.20:38:25
Resolved by:

Mon Sep 29 18:19:48 MSD 2008  Dmitry Kurochkin <dmitry.kurochkin@gmail.com>
  * Resolve issue1105: check if default options are valid.

Wed Oct  1 21:59:07 MSD 2008  David Roundy <droundy@darcs.net>
  * fix bug in 1105 fix that led to improper overrides of defaults
  The problem is illustrated in the tests/override-defaults.sh that I've
  recorded separately.  We want conflicting defaults in
  ~/.darcs/defaults and _darcs/prefs/defaults to be resolved in favor of
  the default residing in _darcs/prefs/defaults.
History
Date User Action Args
2008-09-27 09:04:49koweycreate
2008-10-01 20:38:33dmitry.kurochkinsetstatus: unread -> resolved-in-unstable
nosy: + thorkilnaur
messages: + msg6196
2009-04-22 03:35:53twbsetstatus: resolved-in-unstable -> resolved
nosy: kowey, dagit, simon, thorkilnaur, jaredj, dmitry.kurochkin, mornfall
2009-08-10 23:46:43adminsetnosy: - dagit
2009-08-25 17:25:47adminsetnosy: + darcs-devel, - simon
2009-08-27 14:19:22adminsetnosy: kowey, darcs-devel, thorkilnaur, jaredj, dmitry.kurochkin, mornfall