darcs

Issue 1122 get --complete should not offer to create a lazy repository

Title get --complete should not offer to create a lazy repository
Priority wishlist Status resolved
Milestone Resolved in
Superseder Nosy List darcs-devel, davidm, dmitry.kurochkin, jaredj, kowey, thorkilnaur, twb
Assigned To
Topics ProbablyEasy, UI

Created on 2008-10-04.13:21:20 by twb, last changed 2010-03-15.11:01:00 by davidm.

Messages
msg6220 (view) Author: twb Date: 2008-10-04.13:21:18
I got this *after* spending an hour downloading patches.  Is it stupid
to offer to create a lazy repository at this point?

$ ssh soy darcs get --complete --tag 2.1.0pre3 http://darcs.net/
[...]
Copying patches 6278/6280
Writing inventory 5/49
Writing inventory 19/49
Welcome to the darcs stable repository.
**********************
Copying patches, to get lazy repository hit ctrl-C...
Unapplying 5 patches.
Finished getting.
msg6492 (view) Author: thorkilnaur Date: 2008-10-28.11:22:51
Thanks a lot. Just to clarify: You would like the offer to create a lazy 
repository to appear at a much earlier point in time. Please correct me if this 
is wrong.

Best regards
Thorkil
msg6496 (view) Author: twb Date: 2008-10-28.12:35:27
On Tue, Oct 28, 2008 at 11:22:57AM -0000, Thorkil Naur wrote:
> Thanks a lot. Just to clarify: You would like the offer to create a
> lazy repository to appear at a much earlier point in time. Please
> correct me if this is wrong.

Really, I think if I have explicitly asked for --complete, it should
not offer to create a lazy repository at all.

AIUI the current behaviour is clearly wrong, because with --complete
it offers to create a lazy repository after that's no longer possible
(because the potentially "lazy" parts have already been downloaded).
msg6499 (view) Author: thorkilnaur Date: 2008-10-28.15:32:22
On Tuesday 28 October 2008 13:35, Trent Buck wrote:
> ...
> Really, I think if I have explicitly asked for --complete, it should
> not offer to create a lazy repository at all.
> 
> AIUI the current behaviour is clearly wrong, because with --complete
> it offers to create a lazy repository after that's no longer possible
> (because the potentially "lazy" parts have already been downloaded).

Thanks a lot, my mistake.

Best regards
Thorkil
msg6500 (view) Author: thorkilnaur Date: 2008-10-28.15:41:21
I am leaving this with wishlist priority, since I presume that it doesn't really 
prevent any particular use of darcs. So now we only need a volunteer to do the 
real work.

Thanks and best regards
Thorkil
msg10219 (view) Author: davidm Date: 2010-03-15.11:00:57
The following patch updated the status of issue1122 to be resolved:

* resolve issue1122: get --complete should not offer to create a lazy repository 
Ignore-this: da8a1d30869e6153c027ae396cc74d56
History
Date User Action Args
2008-10-04 13:21:20twbcreate
2008-10-28 11:22:56thorkilnaursetstatus: unread -> unknown
priority: wishlist
title: stupid --complete lazy message? -> get => Message "Copying patches, to get lazy repository hit ctrl-C..." should appear earlier in time
nosy: + jaredj
messages: + msg6492
topic: + ProbablyEasy, UI
2008-10-28 12:35:29twbsetnosy: kowey, dagit, simon, twb, thorkilnaur, jaredj, dmitry.kurochkin
messages: + msg6496
2008-10-28 15:32:24thorkilnaursetnosy: kowey, dagit, simon, twb, thorkilnaur, jaredj, dmitry.kurochkin
messages: + msg6499
title: get => Message "Copying patches, to get lazy repository hit ctrl-C..." should appear earlier in time -> get --complete should not offer to create a lazy repository
2008-10-28 15:41:26thorkilnaursetstatus: unknown -> needs-reproduction
nosy: kowey, dagit, simon, twb, thorkilnaur, jaredj, dmitry.kurochkin
messages: + msg6500
2009-08-10 17:47:05koweysetstatus: needs-reproduction -> needs-implementation
nosy: kowey, dagit, simon, twb, thorkilnaur, jaredj, dmitry.kurochkin
2009-08-10 23:47:25adminsetnosy: - dagit
2009-08-25 17:30:10adminsetnosy: + darcs-devel, - simon
2009-08-26 17:28:34koweysetnosy: kowey, darcs-devel, twb, thorkilnaur, jaredj, dmitry.kurochkin
2009-08-27 14:22:14adminsetnosy: kowey, darcs-devel, twb, thorkilnaur, jaredj, dmitry.kurochkin
2010-03-15 11:01:00davidmsetstatus: needs-implementation -> resolved
nosy: + davidm
messages: + msg10219