darcs

Issue 121 wish: amend-record --ask-deps

Title wish: amend-record --ask-deps
Priority feature Status resolved
Milestone 2.5.0 Resolved in 2.5.0
Superseder Nosy List Serware, bfr, darcs-devel, dmitry.kurochkin, ganesh, greenrd, jaredj, kowey, markstos, thorkilnaur, tommy, twb, zooko
Assigned To ganesh
Topics ProbablyEasy

Created on 2006-01-31.18:01:15 by zooko, last changed 2010-06-15.20:59:19 by admin.

Messages
msg448 (view) Author: zooko Date: 2006-01-31.18:01:14
I currently do it by cleaning up all unrecorded changes, making a copy of the
patch description, darcs unrecord, darcs record --all --ask-deps, then re-paste
in the patch description.  Similarly I wish for darcs amend-record to
optionally prompt me for a new patch description.

Regards,

Zooko
msg2873 (view) Author: markstos Date: 2008-01-30.00:38:55
I'm surprised this hasn't gotten a "me too" in the two years since it has been
open, or had another dupe in the system. It's something I've expected to be
there myself at various times.
msg5172 (view) Author: bfr Date: 2008-07-03.13:36:39
Just needed it today, so, here is my loud and clear "ME TOO" ;)
It is really surprising that this wasn't added when amend-record got the 
edit-... option.
msg8676 (view) Author: kowey Date: 2009-09-04.09:04:53
Merging in issue1451.  I'm also promoting this to a feature because it seems
quite clear that this would be a good thing to have.  

This would probably make for a very good newbie bug: both relatively easy (I
believe) with high satisfaction :-), so I'll mark it as a target for 2.4 in case
nobody gets to it before the next darcs hacking sprint.
msg9661 (view) Author: ganesh Date: 2009-12-22.21:35:01
I'm working on this, though I only expect to get it mostly done.

I saw "mostly" because my implementation won't allow one to remove existing
dependencies, just add new ones - SelectChanges doesn't have any facility I'm
aware of to default certain answers to yes, which is how I think that would have
to work.
msg9743 (view) Author: ganesh Date: 2010-01-07.09:48:39
The following patch updated the status of issue121 to be resolved:

* Resolve issue121: add --ask-deps support to amend-record 
Ignore-this: 8dc5e5728eb91e96db5fcc56c1a2d8f1
msg11377 (view) Author: ganesh Date: 2010-06-13.16:51:12
The following patch updated the status of issue121 to be resolved-in-stable:

* Resolve issue121: add --ask-deps support to amend-record 
Ignore-this: 8dc5e5728eb91e96db5fcc56c1a2d8f1
History
Date User Action Args
2006-01-31 18:01:15zookocreate
2006-02-06 12:42:30droundysetnosy: droundy, tommy, zooko
2008-01-30 00:38:56markstossetstatus: unread -> unknown
nosy: + markstos, kowey, beschmi
messages: + msg2873
2008-02-11 01:31:26markstossetstatus: unknown -> deferred
nosy: droundy, tommy, beschmi, kowey, markstos, zooko
topic: + Confirmed, Darcs2
title: I wish for "darcs amend-record --ask-deps". -> wish: amend-record --ask-deps
2008-07-03 13:36:47benjamin.franksensetnosy: + Serware, dagit, benjamin.franksen
messages: + msg5172
2009-02-02 14:18:25greenrdsetnosy: + greenrd, dmitry.kurochkin, simon, thorkilnaur
2009-08-06 17:49:37adminsetnosy: + jast, darcs-devel, mornfall, - droundy, benjamin.franksen, greenrd
2009-08-06 20:48:41adminsetnosy: - beschmi
2009-08-10 21:43:31adminsetnosy: + greenrd, benjamin.franksen, - darcs-devel, jast, mornfall
2009-08-10 23:51:18adminsetnosy: - dagit
2009-08-25 17:40:21adminsetnosy: + darcs-devel, - simon
2009-08-27 14:01:04adminsetnosy: tommy, kowey, markstos, darcs-devel, zooko, benjamin.franksen, thorkilnaur, dmitry.kurochkin, Serware, greenrd
2009-09-04 09:02:04koweylinkissue1451 superseder
2009-09-04 09:05:00koweysetpriority: wishlist -> feature
status: deferred -> needs-implementation
topic: + ProbablyEasy, Target-2.4, - Confirmed, Darcs2
messages: + msg8676
nosy: + bfr, twb, jaredj
2009-09-14 10:52:37koweysettopic: + Target-2.5, - Target-2.4
nosy: tommy, kowey, markstos, darcs-devel, zooko, benjamin.franksen, twb, thorkilnaur, jaredj, dmitry.kurochkin, Serware, bfr, greenrd
2009-10-23 22:35:20adminsetnosy: - bfr
2009-10-23 22:43:29adminsetnosy: + serware, - Serware
2009-10-23 23:29:24adminsetnosy: + Serware, - serware
2009-10-23 23:46:01adminsetnosy: + bfr, - benjamin.franksen
2009-12-22 21:35:09ganeshsetstatus: needs-implementation -> has-patch
nosy: + ganesh
messages: + msg9661
assignedto: ganesh
2009-12-28 22:59:27ganeshlinkpatch122 issues
2010-01-07 09:48:43ganeshsetstatus: has-patch -> resolved
messages: + msg9743
2010-06-13 16:51:14ganeshsetstatus: resolved -> resolved-in-stable
messages: + msg11377
2010-06-13 17:49:56koweysetstatus: resolved-in-stable -> resolved
milestone: 2.5.0
resolvedin: 2.5.0
2010-06-15 20:59:19adminsettopic: - Target-2.5