darcs

Issue 1277 darcs add, remove, etc should report repository format errors as such

Title darcs add, remove, etc should report repository format errors as such
Priority feature Status resolved
Milestone 2.5.0 Resolved in 2.5.0
Superseder Nosy List darcs-devel, dmitry.kurochkin, ganesh, jaredj, kowey, thorkilnaur, tux_rocker, twb
Assigned To kowey
Topics UI

Created on 2008-12-22.11:39:57 by kowey, last changed 2010-07-01.21:22:00 by kowey.

Messages
msg6862 (view) Author: kowey Date: 2008-12-22.11:39:44
Current (bad) behaviour: If I do darcs add or remove in a repository with a
format darcs does not recognise (in this case darcs-2-experimental), it
complains that it is not in a repository.

Desired behaviour: it should complain that it does not recognise the format
darcs-2-experimental

Note that other commands do this just fine, e.g. darcs changes

[Note: this is what I would normally mark as a bug, but I'm trying to follow the
new convention proposed by Thorkil,
http://wiki.darcs.net/index.html/BugTrackerIssueManagement so I'm putting this
down as a wishlist item... I hope I got it right]
msg7041 (view) Author: twb Date: 2009-01-11.14:49:18
It seems to me that the first step for this is to produce a
test script for bugs/.  Eric, would you like to do this?
msg8343 (view) Author: kowey Date: 2009-08-22.11:25:03
Assigning to myself to write a test for this.  It's important to me that we take
care of this fairly early to better accommodate future changes to the format file.
msg10310 (view) Author: ganesh Date: 2010-03-20.11:21:42
Just to note that because we are planning on adding a new format for 
rebase, which itself has probably slipped to 2.6, we really should do this 
one for 2.5.
msg10341 (view) Author: kowey Date: 2010-03-21.06:40:37
See also issue1647
msg11477 (view) Author: tux_rocker Date: 2010-06-18.17:25:44
Kowey, if it's important given the oncoming format work and it's
probably easy, maybe you can do this one quickly before the freeze?
msg11481 (view) Author: kowey Date: 2010-06-18.19:05:52
Test submitted (need-implementation); code review under way (in-progress)
msg11601 (view) Author: kowey Date: 2010-06-27.13:47:44
The following patch updated issue issue1277 with status=resolved;resolvedin=2.6.0 HEAD

* Resolve issue1277: percolate repository format errors correctly. 
Ignore-this: b541efa39c3b55b67479b209f55ffd1d
The problem is that we do not distinguish between bad repos and
non-repositories so we keep seeking upwards.
msg11672 (view) Author: kowey Date: 2010-07-01.21:21:59
The following patch updated issue issue1277 with status=resolved;resolvedin=2.5.0 CURRENT

* Resolve issue1277: percolate repository format errors correctly. 
Ignore-this: b541efa39c3b55b67479b209f55ffd1d
The problem is that we do not distinguish between bad repos and
non-repositories so we keep seeking upwards.
History
Date User Action Args
2008-12-22 11:39:57koweycreate
2009-01-11 14:49:21twbsetstatus: unread -> unknown
nosy: + twb
messages: + msg7041
2009-08-22 11:25:10koweysetstatus: unknown -> needs-reproduction
topic: + Target-2.4
nosy: kowey, simon, twb, thorkilnaur, jaredj, dmitry.kurochkin
messages: + msg8343
priority: wishlist -> feature
assignedto: kowey
2009-08-25 17:36:39adminsetnosy: + darcs-devel, - simon
2009-08-27 14:29:21adminsetnosy: kowey, darcs-devel, twb, thorkilnaur, jaredj, dmitry.kurochkin
2010-03-01 13:21:56koweysettopic: + Target-2.5, - Target-2.4
2010-03-20 11:21:50ganeshsetnosy: + ganesh
messages: + msg10310
2010-03-21 06:40:44koweysetmessages: + msg10341
2010-06-15 20:52:07adminsetmilestone: 2.5.0
2010-06-15 20:59:43adminsettopic: - Target-2.5
2010-06-18 17:25:44tux_rockersetnosy: + tux_rocker
messages: + msg11477
2010-06-18 19:05:54koweysetstatus: needs-reproduction -> has-patch
topic: - ProbablyEasy
messages: + msg11481
2010-06-18 19:06:42koweylinkpatch283 issues
2010-06-27 13:47:45koweysetstatus: has-patch -> resolved
messages: + msg11601
resolvedin: 2.8.0
2010-07-01 21:22:00koweysetmessages: + msg11672
resolvedin: 2.8.0 -> 2.5.0