Issue 1361 Configure fails to detect curl absence

Title Configure fails to detect curl absence
Priority bug Status resolved
Milestone Resolved in
Superseder Nosy List darcs-devel, dmitry.kurochkin, kowey, thorkilnaur, tux_rocker
Assigned To tux_rocker

Created on 2009-02-14.23:52:51 by tux_rocker, last changed 2009-08-27.14:15:42 by admin.

msg7315 (view) Author: tux_rocker Date: 2009-02-14.23:52:48
When I "cabal configure" on my Ubuntu Intrepid with a virgin GHC 6.10.1 from the
x86_64 binary package, I see no messages. But when I "cabal build", I get:

[134 of 134] Compiling Darcs.RunCommand ( src/Darcs/RunCommand.hs,
dist/build/Darcs/RunCommand.o )                                          

src/hscurl.c:5:23:  error: curl/curl.h: Bestand of map bestaat niet

     fout: expected ‘,’ or ‘;’ before ‘LIBCURL_VERSION’

Some more information:

$ ghc-pkg list
    Cabal-, HUnit-, QuickCheck-, array-,
    base-, base-, bytestring-, containers-,
    directory-, (dph-base-0.3), (dph-par-0.3),
    (dph-prim-interface-0.3), (dph-prim-par-0.3), (dph-prim-seq-0.3),
    (dph-seq-0.3), editline-, filepath-, (ghc-6.10.1),
    ghc-prim-, haddock-2.3.0, haskell-src-,
    haskell98-, hpc-, html-, integer-,
    mtl-, network-, old-locale-, old-time-,
    packedstring-, parallel-, parsec-,
    pretty-, process-, random-,
    regex-base-, regex-compat-, regex-posix-,
    rts-1.0, stm-, syb-, template-haskell-,
    time-, unix-, xhtml-3000.2.0.1

Installing the libcurl-dev distribution package makes it build. The problem is
that darcs does not fail during configure and gives an unclear message when it
fails during build.
msg7316 (view) Author: tux_rocker Date: 2009-02-15.11:50:35
It appears that the feature of checking for C libraries and/or headers at
configure time was added to Cabal a few weeks ago:
http://hackage.haskell.org/trac/hackage/ticket/262 .
msg7318 (view) Author: tux_rocker Date: 2009-02-15.18:37:05
The following patch updated the status of issue1361 to be resolved:

* resolve issue1361: specify required includes for curl in cabal file 
Ignore-this: 2581d04c7534d750575dd4732911fb8f
Date User Action Args
2009-02-14 23:52:51tux_rockercreate
2009-02-15 10:48:34tux_rockersetnosy: kowey, simon, thorkilnaur, tux_rocker, dmitry.kurochkin
assignedto: tux_rocker
2009-02-15 11:50:38tux_rockersetstatus: unread -> unknown
nosy: kowey, simon, thorkilnaur, tux_rocker, dmitry.kurochkin
messages: + msg7316
2009-02-15 18:37:08tux_rockersetstatus: unknown -> resolved
nosy: kowey, simon, thorkilnaur, tux_rocker, dmitry.kurochkin
messages: + msg7318
2009-08-25 17:40:59adminsetnosy: + darcs-devel, - simon
2009-08-27 14:15:42adminsetnosy: kowey, darcs-devel, thorkilnaur, tux_rocker, dmitry.kurochkin