Issue 1551 only use 'file content did not change' prompt for darcs send

Title only use 'file content did not change' prompt for darcs send
Priority feature Status resolved
Milestone 2.8.0 Resolved in 2.8.0
Superseder Nosy List darcs-devel, dmitry.kurochkin, jaredj, kowey, thorkilnaur
Assigned To kowey
Topics ProbablyEasy, Regression, UI

Created on 2009-08-22.16:36:01 by kowey, last changed 2011-10-27.02:10:52 by kowey.

msg8358 (view) Author: kowey Date: 2009-08-22.16:35:48
I consider this a UI regression from our issue1186 fix.

If I record patches and edit the long comment without actually making any
changes (this happens a lot), I get this prompt
  "File content did not change. Continue anyway?"

This irritates me and wastes my time in two ways:
1. it breaks my train of thought so that I can think about the answer to the
2. I often hit 'n' when I really mean 'y' and have to start all over again

Now this is useful for darcs send --edit-description because there you don't
really get a good way to abort the send, but it just drives me up the wall when
I'm doing darcs record and amend-record.

PS. I know that I tend to be a broken record about this, but Donald Norman's
/The Design of Everyday Things/ explains why it's usually better to have an
'undo' feature than a confirmation dialogue.  People like me just tend to make
the confirmation dialogue 'go away' (hit n, click Cancel or Yes) only to regret
it later.  I think it's applicable here.  You can always amend
--edit-long-comment if you have to.
msg8359 (view) Author: kowey Date: 2009-08-22.16:36:54
Code-wise the solution seems to be to make Darcs.Utils.edit_file parameterisable
with a warnIfUnchanged flag.
msg10600 (view) Author: kowey Date: 2010-03-31.21:53:36
Since this one annoys me so much, I should probably take it on (this is
a newbie bug that I'd love to see somebody fix, so please please feel
free to step in and say "nah, I'll do it...")
msg13031 (view) Author: noreply Date: 2010-11-14.16:15:55
The following patch sent by Eric Kow <kowey@darcs.net> updated issue issue1551 with
status=resolved;resolvedin=2.8.0 HEAD

* Resolve issue1551: only use unchanged file content prompt in darcs send. 
Ignore-this: 61cc0bf71ff2c54311834624b2a7f6d7
msg14786 (view) Author: markstos Date: 2011-10-27.02:05:09
Here's my story about making dialogs just go away. I was riding with my 
parents on a long trip to Canada from the midwest US, using a new GPS 
device. As part of setting the route, a familiar screen came up that I 
recognized and I quickly clicked through it on to the next. 

As we got closer to Canada, we were surprised to diverted off the 
interstate when it seemed that it would be fastest. But hey, we trusted 
the GPS device. 

I think it had asked me a negative question like "Avoid Toll Roads?" and 
I must have yet "yes", which sent us off the interstate (where we would 
likely pay more in gas for the longer route than we would pay in tools). 

What I meant was "Yes, toll roads are fine, just whatever, get of the 
way, I want to get the important screen just after this one". 

Thanks for your persistence here, Eric.
Date User Action Args
2009-08-22 16:36:01koweycreate
2009-08-22 16:37:04koweysetnosy: kowey, simon, thorkilnaur, jaredj, dmitry.kurochkin
messages: + msg8359
2009-08-25 18:15:58adminsetnosy: + darcs-devel, - simon
2009-08-27 14:29:42adminsetnosy: kowey, darcs-devel, thorkilnaur, jaredj, dmitry.kurochkin
2009-09-14 10:50:11koweysettopic: + Target-2.5, - Target-2.4
nosy: kowey, darcs-devel, thorkilnaur, jaredj, dmitry.kurochkin
2010-03-31 21:53:40koweysetassignedto: kowey
messages: + msg10600
2010-06-15 20:51:52adminsetmilestone: 2.5.0
2010-06-15 20:59:11adminsettopic: - Target-2.5
2010-07-25 14:34:01tux_rockersetmilestone: 2.5.0 -> 2.8.0
2010-11-14 16:15:56noreplysetstatus: needs-implementation -> resolved
messages: + msg13031
resolvedin: 2.8.0
2011-10-27 02:05:10markstossetstatus: resolved -> unknown
messages: + msg14786
2011-10-27 02:10:52koweysetstatus: unknown -> resolved