darcs

Issue 1554 cannot build on Alpha, ld: cannot find -lHSrts_thr

Title cannot build on Alpha, ld: cannot find -lHSrts_thr
Priority bug Status resolved
Milestone Resolved in
Superseder Nosy List darcs-devel, dmitry.kurochkin, kowey, thorkilnaur, twb
Assigned To
Topics Devel

Created on 2009-08-23.12:14:01 by twb, last changed 2009-11-01.12:37:04 by twb.

Messages
msg8396 (view) Author: twb Date: 2009-08-23.12:13:58
http://buildd.debian.org/build.php?arch=alpha&pkg=darcs&ver=2.3.0-1,
it appears that Darcs 2.3.0 fails to build on Alpha systems, due to

    ld: cannot find -lHSrts_thr

The good folk of #haskell think RTS probably isn't available on Alpha,
and that we can/should resolve this by making -threaded optional in
the .cabal file, especially in an if !arch(alpha) or so.
msg8397 (view) Author: twb Date: 2009-08-23.12:17:29
Sigh.  Because msg8396 started a line with "From ", and roundup
apparently doesn't handle that correctly, that line was thrown away.

It was a link to http://bugs.debian.org/541848
msg8398 (view) Author: kowey Date: 2009-08-23.12:22:41
I think we need somebody to verify that Darcs actually even works if you build
it without -threaded

I think we need it for progress reporting to work if nothing else.

(For those like me are not immersed in all the developer slang, that's 'Fails To
Build From Source" -- http://en.wikipedia.org/wiki/FTBFS )
msg8446 (view) Author: twb Date: 2009-08-24.01:58:50
On Sun, Aug 23, 2009 at 12:22:45PM +0000, Eric Kow wrote:
> I think we need somebody to verify that Darcs actually even works if
> you build it without -threaded

It does; all the tests pass except check.sh, which looks like it
failed due to OpenVZ and NFS saying a directory has been deleted
before it actually IS deleted.

> I think we need it for progress reporting to work if nothing else.

If nothing else, this bug indicates that we need to add a comment to
that effect in the .cabal file.

Certainly when I ran the build without "-threaded" in the .cabal file
(on x86-64), a "darcs get http://darcs.net" gave me lines like

    Copying pristine 157/236 : Email.hs

and

    Copying patches 2188/7685 : back to TAG 2.0.0rc1

Maybe I have IMPLICITLY build with -threaded on, because something has
decided it's necessary?
msg8448 (view) Author: kowey Date: 2009-08-24.08:09:40
On Mon, Aug 24, 2009 at 01:58:52 +0000, Trent W. Buck wrote:
> Maybe I have IMPLICITLY build with -threaded on, because something has
> decided it's necessary?

Interesting.  The cabal file has a bit of duplication.  Are you sure
you've removed all instances of -threaded?

If so, the next step may be to have a user on Alpha give this a try.
msg8450 (view) Author: kowey Date: 2009-08-24.11:00:34
Also: the following darcs changes -p threaded may be of interest:

Fri May  9 20:58:33 BST 2008  David Roundy <droundy@darcs.net>
  * resolve Issue739: compile with threaded runtime by default.
  It turns out that the tempfile-removal cleanup wasn't particularly feasible
  without the threaded runtime.
msg9162 (view) Author: twb Date: 2009-11-01.12:37:00
The following patch updated the status of issue1554 to be resolved:

* Resolve issue1554: allow opt-out of -threaded (fix ARM builds). 
Ignore-this: 19823ea41b53b5b6ef2a3b5c19de7516
GHC doesn't support -threaded on some architectures.
This patch allows -f-threaded, so Darcs will compile again.
History
Date User Action Args
2009-08-23 12:14:01twbcreate
2009-08-23 12:17:31twbsetnosy: - 541848
messages: + msg8397
2009-08-23 12:22:45koweysetstatus: unknown -> needs-reproduction
topic: + Devel
title: FTBFS on Alpha, ld: cannot find -lHSrts_thr -> cannot build on Alpha, ld: cannot find -lHSrts_thr
nosy: kowey, simon, twb, thorkilnaur, dmitry.kurochkin
messages: + msg8398
priority: bug
2009-08-24 01:58:52twbsetnosy: kowey, simon, twb, thorkilnaur, dmitry.kurochkin
messages: + msg8446
2009-08-24 08:09:42koweysetnosy: kowey, simon, twb, thorkilnaur, dmitry.kurochkin
messages: + msg8448
2009-08-24 11:00:38koweysetnosy: kowey, simon, twb, thorkilnaur, dmitry.kurochkin
messages: + msg8450
2009-08-25 18:16:04adminsetnosy: + darcs-devel, - simon
2009-08-27 14:31:39adminsetnosy: kowey, darcs-devel, twb, thorkilnaur, dmitry.kurochkin
2009-10-31 09:03:29koweylinkpatch22 issues
2009-11-01 12:37:04twbsetstatus: needs-reproduction -> resolved
messages: + msg9162