darcs

Issue 1610 bug in get_extra commuting patches (darcs 1 semantics)

Title bug in get_extra commuting patches (darcs 1 semantics)
Priority bug Status needs-reproduction
Milestone Resolved in
Superseder Nosy List dmitry.kurochkin, kowey, momo54, mornfall
Assigned To
Topics Core

Created on 2009-09-12.16:20:53 by kowey, last changed 2010-06-15.22:45:20 by kowey.

Files
File name Uploaded Type Edit Remove
failing-1610_get_extra.sh kowey, 2009-09-12.16:20:51 application/x-sh
Messages
msg8795 (view) Author: kowey Date: 2009-09-12.16:20:51
I accidentally stumbled on this trying to write the test for issue1609.
By flipping the order of a pull, I was able to get the darcs-1 semantics
repo to choke.
Attachments
msg8805 (view) Author: kowey Date: 2009-09-13.23:09:17
This looks like a proper bug from
http://irclog.perlgeek.de/darcs/2009-09-13#i_1497194
...and it needs investigating.
msg11294 (view) Author: mornfall Date: 2010-06-06.19:53:33
The following patch updated the status of issue1610 to be resolved:

* Resolve issue1610: mark the test as passing. Likely fixed by NewSet. 
Ignore-this: 9145934b0ca0f45033153a51071ae6f2
msg11452 (view) Author: mornfall Date: 2010-06-15.22:40:13
The following patch updated issue issue1610 with status=resolved;resolvedin=2.5.0 (current)

* Resolve issue1610: mark the test as passing. Likely fixed by NewSet. 
Ignore-this: 9145934b0ca0f45033153a51071ae6f2
msg11457 (view) Author: kowey Date: 2010-06-15.22:45:19
Whoops! We later discovered that this test was passing for the wrong
reason.  We need to make it more rigorous.
History
Date User Action Args
2009-09-12 16:20:53koweycreate
2009-09-13 23:09:22koweysetpriority: bug
status: unknown -> needs-reproduction
topic: + Core
messages: + msg8805
nosy: kowey, darcs-devel, dmitry.kurochkin, momo54
2009-10-22 09:44:41koweylinkpatch2 issues
2010-06-06 19:53:34mornfallsetstatus: needs-reproduction -> resolved
nosy: + mornfall
messages: + msg11294
2010-06-15 22:40:14mornfallsetmessages: + msg11452
resolvedin: 2.5.0
2010-06-15 22:45:20koweysetstatus: resolved -> needs-reproduction
nosy: - darcs-devel
messages: + msg11457
resolvedin: 2.5.0 ->