darcs

Issue 1815 Permissions in release tarballs are wrong

Title Permissions in release tarballs are wrong
Priority not-our-bug Status resolved
Milestone 2.5.0 Resolved in 2.5.0
Superseder Nosy List dmitry.kurochkin, kili, kowey, tux_rocker
Assigned To tux_rocker
Topics Devel

Created on 2010-04-13.20:56:56 by tux_rocker, last changed 2010-08-27.20:21:56 by tux_rocker.

Messages
msg10721 (view) Author: tux_rocker Date: 2010-04-13.20:56:55
This was reported to my personal mail by Matthias Kilian.

In the darcs 2.4.1 tarball, the regular files have 0600 (owner may read and 
write, no rights for others) as the permission bits, where 0644 (owner may 
write, everyone may read) would be more logical. In the working copy of the 
repo that I created the tarball from, it *is* actually 0644. The files already 
had the wrong permissions in the 2.4 tarball.

Our tarballs are made by 'cabal sdist' via the 'release/release.sh' script. 
The latter script does not contain any suspicious activity wrt to permissions 
as far as I can judge.
msg10722 (view) Author: tux_rocker Date: 2010-04-13.20:59:55
It seems that our colleagues over at Cabal already fixed this, see the
thread at
http://www.haskell.org/pipermail/cabal-devel/2010-January/006054.html .
Tomorrow I'll try if upgrading Cabal solves it.
msg11139 (view) Author: kowey Date: 2010-05-28.20:35:29
I'm making Matthias nosy on this ticket as he reported the initial issue.

Did upgrading Cabal solve the problem, Reinier?
msg11414 (view) Author: tux_rocker Date: 2010-06-14.17:23:08
> Did upgrading Cabal solve the problem, Reinier?

I haven't tried, and reading the ticket again, the Cabal people
haven't fixed it. You have to use 'cabal sdist' instead of 'runghc
Setup.hs sdist'. We'll try that, then.
msg11415 (view) Author: kowey Date: 2010-06-14.17:33:54
Is there a Cabal ticket we need to link against?

(I really don't want us to the be sort of silent user that works around
bugs and never percolates them upstream...)
msg11416 (view) Author: tux_rocker Date: 2010-06-14.19:27:26
> Is there a Cabal ticket we need to link against?

http://hackage.haskell.org/trac/hackage/ticket/627 . Is there a specific way 
to link against it?
msg11417 (view) Author: kowey Date: 2010-06-14.19:35:08
Nope, we could add one if we need it.  

Marking not-our-bug (now that we've done everything that's in our power)
and waiting-for (since there's nothing for us as darcs hackers to do
except wait for some pre-requisite to be fulfilled, here the Cabal team
fixing the bug).  [The reason I'm sometimes painfully explicit about
this is my hope that I'm implicitly training any potential future IM
that may be reading this].
msg12200 (view) Author: tux_rocker Date: 2010-08-15.20:31:11
We have to get this right somehow for the 2.5 release. But "cabal sdist"
is not working on darcs for murky reasons, while "runghc Setup.lhs
sdist" does work.

We have to make "cabal sdist" work in order to get the permissions right.
msg12277 (view) Author: tux_rocker Date: 2010-08-23.18:57:12
The following patch updated issue issue1815 with status=resolved;resolvedin=2.5.0 CURRENT

* resolve issue1815: work around Cabal sdist permissions issue 
Ignore-this: e8e9a63a9cdeaea1332c961cdba61b09
msg12278 (view) Author: tux_rocker Date: 2010-08-23.20:18:51
The following patch updated issue issue1815 with status=resolved;resolvedin=2.8.0 HEAD

* resolve issue1815: work around Cabal sdist permissions issue 
Ignore-this: e8e9a63a9cdeaea1332c961cdba61b09
History
Date User Action Args
2010-04-13 20:56:56tux_rockercreate
2010-04-13 20:59:56tux_rockersetmessages: + msg10722
2010-05-28 20:35:30koweysetstatus: unknown -> needs-reproduction
topic: + Devel
nosy: + kowey, kili, - darcs-devel
messages: + msg11139
priority: bug
assignedto: tux_rocker
2010-06-14 17:23:08tux_rockersetmessages: + msg11414
2010-06-14 17:33:54koweysetmessages: + msg11415
2010-06-14 19:27:27tux_rockersetmessages: + msg11416
2010-06-14 19:35:09koweysetpriority: bug -> not-our-bug
status: needs-reproduction -> waiting-for
messages: + msg11417
2010-08-15 20:31:12tux_rockersetmessages: + msg12200
milestone: 2.5.0
2010-08-23 18:57:13tux_rockersetstatus: waiting-for -> resolved
messages: + msg12277
resolvedin: 2.5.0
2010-08-23 20:18:52tux_rockersetmessages: + msg12278
resolvedin: 2.5.0 -> 2.8.0
2010-08-27 20:21:56tux_rockersetresolvedin: 2.8.0 -> 2.5.0