darcs

Issue 1848 interactive rollback no longer lets you select primitive patches

Title interactive rollback no longer lets you select primitive patches
Priority bug Status resolved
Milestone 2.5.0 Resolved in 2.5.0
Superseder Nosy List dmitry.kurochkin, galbolle, jaredj, kowey
Assigned To kowey
Topics ProbablyEasy, Regression, UI

Created on 2010-05-22.17:31:35 by kowey, last changed 2010-06-15.22:40:12 by galbolle.

Messages
msg11099 (view) Author: kowey Date: 2010-05-22.17:31:34
I was using -p if it changes anything.
I think this may be a regression

-- 
Eric Kow <http://www.nltg.brighton.ac.uk/home/Eric.Kow>
PGP Key ID: 08AC04F9
msg11100 (view) Author: kowey Date: 2010-05-22.17:35:26
On Sat, May 22, 2010 at 17:31:35 +0000, Eric Kow wrote:
> I was using -p if it changes anything.
> I think this may be a regression

I can confirm that darcs-2.4.4 handles this case fine
(and that you have to use a matcher to trigger this)

This is why it's a good idea for the Darcs Team to be using Darcs HEAD
if possible... bugs take a long time to discover :-)

-- 
Eric Kow <http://www.nltg.brighton.ac.uk/home/Eric.Kow>
PGP Key ID: 08AC04F9
msg11151 (view) Author: kowey Date: 2010-05-29.13:52:38
Assigning to myself to create a test case (is that even a good idea here?).

Making Florent nosy because there's a chance this is related to the
recent refactor.
msg11202 (view) Author: kowey Date: 2010-06-02.20:05:30
On Sat, May 29, 2010 at 13:52:41 +0000, Eric Kow wrote:
> Assigning to myself to create a test case (is that even a good idea here?).

Done.  (and confirmed that it passes on darcs-2.4.3)

> Making Florent nosy because there's a chance this is related to the
> recent refactor.

Florent: could you have a look?

-- 
Eric Kow <http://www.nltg.brighton.ac.uk/home/Eric.Kow>
PGP Key ID: 08AC04F9
msg11203 (view) Author: kowey Date: 2010-06-02.20:10:29
On Wed, Jun 02, 2010 at 20:05:30 +0000, Eric Kow wrote:
> Done.  (and confirmed that it passes on darcs-2.4.3)

Sigh, why write one mail when you can write two?

I meant to say that I pushed this directly to the repo
(as we've loosened the commit policy so that tests get fast-tracked that
way)

-- 
Eric Kow <http://www.nltg.brighton.ac.uk/home/Eric.Kow>
PGP Key ID: 08AC04F9
msg11216 (view) Author: galbolle Date: 2010-06-03.16:54:51
The following patch updated the status of issue1848 to be resolved:

* resolve issue1848: Patch.Choices.makeEverythingSooner is incorrect 
Ignore-this: ef9ea4cb04d313c668b3854409e5f451
This made selection of patches with --match buggy when choosing Last or
FirstReversed patches. This affected primary patch selection in rollback,
record --ask, and any other command with --reverse.
msg11448 (view) Author: galbolle Date: 2010-06-15.22:40:11
The following patch updated issue issue1848 with status=resolved;resolvedin=2.5.0 (current)

* resolve issue1848: Patch.Choices.makeEverythingSooner is incorrect 
Ignore-this: ef9ea4cb04d313c668b3854409e5f451
This made selection of patches with --match buggy when choosing Last or
FirstReversed patches. This affected primary patch selection in rollback,
record --ask, and any other command with --reverse.
History
Date User Action Args
2010-05-22 17:31:35koweycreate
2010-05-22 17:35:27koweysetmessages: + msg11100
2010-05-29 13:52:41koweysetstatus: unknown -> needs-reproduction
topic: + ProbablyEasy, UI, Regression, Target-2.5
nosy: + galbolle, jaredj
messages: + msg11151
priority: bug
assignedto: kowey
2010-06-02 20:05:30koweysetmessages: + msg11202
2010-06-02 20:10:30koweysetmessages: + msg11203
2010-06-03 16:54:51galbollesetstatus: needs-reproduction -> resolved
messages: + msg11216
2010-06-15 20:52:16adminsetmilestone: 2.5.0
2010-06-15 21:00:08adminsettopic: - Target-2.5
2010-06-15 22:40:12galbollesetmessages: + msg11448
resolvedin: 2.5.0