Issue 1884 darcs get wrongly reports "getting lazy repository" when you hit C-c (incomplete fetching)

Title darcs get wrongly reports "getting lazy repository" when you hit C-c (incomplete fetching)
Priority bug Status resolved
Milestone 2.8.0 Resolved in 2.8.0
Superseder Nosy List dmitry.kurochkin, exlevan, kowey, mornfall
Assigned To exlevan
Topics Control-C, HTTP, Hashed, Regression

Created on 2010-07-01.10:05:42 by kowey, last changed 2010-09-03.21:06:23 by exlevan.

msg11660 (view) Author: kowey Date: 2010-07-01.10:05:39
Don't mean to pick on you, Alexey :-)

I was playing with darcs get http://darcs.net on HEAD.  I did a get and
hit C-c (presumably while darcs was fetching a pack) and Darcs lied to
me! It told me it was fetching a lazy repository and that it
successfully fetched the repository, but instead what I got appeared to
be an empty repository. 

I suspect this is a regression from optimize --http usage.
May I ask you to identify the cause for this behaviour?

Many thanks!  (We'll get there! Just a bit of tuning...)
msg12449 (view) Author: exlevan Date: 2010-09-03.21:06:22
The following patch updated issue issue1884 with status=resolved;resolvedin=2.8.0 HEAD

* Resolve issue1884: correct report about getting lazy repository 
Ignore-this: b533c7d2c508ae33ef37a01faa7e0863
Date User Action Args
2010-07-01 10:05:42koweycreate
2010-07-25 14:29:46tux_rockersetmilestone: 2.5.0 -> 2.8.0
2010-09-03 21:06:23exlevansetstatus: needs-reproduction -> resolved
messages: + msg12449
resolvedin: 2.8.0