darcs

Issue 1898 when interacting with non-default repo, remind user about --set-default

Title when interacting with non-default repo, remind user about --set-default
Priority feature Status
Milestone Resolved in
Superseder Nosy List dmitry.kurochkin, ganesh, jaredj, kowey, tux_rocker
Assigned To
Topics ProbablyEasy, UI

Created on 2010-07-25.15:01:51 by kowey, last changed 2015-02-14.17:18:42 by bf.

Messages
msg11852 (view) Author: kowey Date: 2010-07-25.15:01:49
See issue1885 and http://wiki.darcs.net/DefaultSwitches.

Action required: confirm that --set-default works even if no actual
actions are taken, eg. if you do an empty darcs push.  (Because the
likely use case is that you see the reminder after you've pushed your
patches...)
msg12098 (view) Author: kowey Date: 2010-08-10.20:21:23
Verifying this took all of 15 seconds.  Yes, if you push --set-default
and there are no patches to push it still sets the default (which is
good).  That makes the message very easy to implement.
msg12099 (view) Author: ganesh Date: 2010-08-10.20:45:38
Since the behaviour change is in 2.5, the helpful text needs to be too.
msg12218 (view) Author: kowey Date: 2010-08-17.16:52:11
The following patch updated issue issue1898 with status=resolved;resolvedin=2.5.0 CURRENT

* Resolve issue1898: notify user when they can use set-default. 
Ignore-this: 638b575b32d700cfae9f057293cd5aa8
msg12267 (view) Author: kowey Date: 2010-08-22.17:02:26
The following patch updated issue issue1898 with status=resolved;resolvedin=2.8.0 HEAD

* Resolve issue1898: notify user when they can use set-default. 
Ignore-this: 638b575b32d700cfae9f057293cd5aa8
msg18139 (view) Author: bf Date: 2015-02-14.17:18:40
I am re-opening this because of two reasons:

(a) Being spammed with messages like this quickly gets boring. An
explicit location on the command line is ample evidence that the user
thinks that this is not the default repo. That means it makes more sense
to display a hint in case the given repo *is* the default repo:

> darcs push -a /path/to/default/repo
Pushed patches to default repo /path/to/default/repo

(User: okay, thanks for telling me, will leave it off next time)

> darcs push -a /path/to/some/other/repo
Pushed patches to specified repo

(User: fine, that worked)

> darcs push -a
Pushed patches to default repo /path/to/default/repo

(User: Ah, so this is where I have just pushed)

Extended hints are okay if --verbose is active.

(b) The currently displayed hint shows a weakness in the UI: the proper
way to set the default repo should be with darcs setpref defaultrepo.
The --set-default switch is okay as a shortcut but should not be the
only or preferred way.
History
Date User Action Args
2010-07-25 15:01:52koweycreate
2010-07-25 15:18:33koweylinkissue1885 superseder
2010-08-10 20:21:24koweysetstatus: needs-reproduction -> needs-implementation
messages: + msg12098
2010-08-10 20:41:31ganeshsetnosy: + ganesh
2010-08-10 20:45:39ganeshsetmessages: + msg12099
milestone: 2.8.0 -> 2.5.0
2010-08-13 06:17:51tux_rockersetnosy: + tux_rocker
2010-08-17 16:52:12koweysetstatus: needs-implementation -> resolved
messages: + msg12218
resolvedin: 2.5.0
2010-08-22 17:02:27koweysetmessages: + msg12267
resolvedin: 2.5.0 -> 2.8.0
2010-08-22 19:19:32tux_rockersetresolvedin: 2.8.0 -> 2.5.0
2015-02-14 17:18:42bfsetstatus: resolved ->
milestone: 2.5.0 ->
messages: + msg18139
resolvedin: 2.5.0 ->