Issue 1948 use nobody@darcs.net for darcs-roundup integration

Title use nobody@darcs.net for darcs-roundup integration
Priority feature Status resolved
Milestone Resolved in 2.8.0
Superseder Nosy List Serware, dmitry.kurochkin, kowey
Assigned To
Topics BugTracker

Created on 2010-09-06.12:57:50 by kowey, last changed 2010-10-16.14:20:52 by noreply.

msg12476 (view) Author: kowey Date: 2010-09-06.12:57:48
Right now you get automated messages saying things like:

  The following patch updated issue issue1864 with
status=resolved;resolvedin=2.5.0 (current)

One problem is that they appear to come from the patch author, which is
less than ideal.  Better would be if it came from some robot user like
nobody@darcs.net (and attributed the author)

Implementation itself is easy, but we may need(-action) to figure out
how to configure a nobody@ address (or noreply, etc) correctly in exim
so that it just systematically goes to /dev/null.

Note that you'll likely also want to make sure there is a roundup user
for this address and that it is set to never_nosy
msg12715 (view) Author: noreply Date: 2010-10-16.14:20:50
The following patch sent by Eric Kow <kowey@darcs.net> updated issue issue1948 with
status=resolved;resolvedin=2.8.0 HEAD

* Resolve issue1948: send BTS update emails as noreply@ 
Ignore-this: 611b31a8670a97f95084b8d8a2f19e21

1. This avoids confusion from pretending to be somebody we are not
   (the patch author)
2. This allows roundup to detect emails from BTS/darcs integration
   (because they would all come from a single email address).
Date User Action Args
2010-09-06 12:57:50koweycreate
2010-10-16 14:20:52noreplysetstatus: needs-reproduction -> resolved
messages: + msg12715
resolvedin: 2.8.0