darcs

Issue 2161 screened repo build failure

Title screened repo build failure
Priority bug Status resolved
Milestone Resolved in 2.10.0 HEAD
Superseder Nosy List fx
Assigned To
Topics

Created on 2012-03-19.21:24:36 by fx, last changed 2012-05-14.13:10:07 by noreply.

Files
File name Uploaded Type Edit Remove
resolve-issue2151.dpatch owst, 2012-03-21.19:41:45 application/octet-stream
Messages
msg15363 (view) Author: fx Date: 2012-03-19.21:24:35
The current http://darcs.net repo fails to build (with ghc 6.12.1):

[175 of 180] Compiling Darcs.Commands.WhatsNew (src/Darcs/Commands/WhatsNew.hs, dist/build/Darcs/Commands/WhatsNew.o )

src/Darcs/Commands/WhatsNew.hs:115:37:
    The scoped type variables `t' and `r'
      are bound to the same type (variable)
      Distinct scoped type variables must be distinct
    In the pattern: repo :: Repository p r u t
    In the second argument of `($)', namely
        `\ (repo :: Repository p r u t)
             -> do { files <- if null args then
                                  return Nothing
                              else  Just <$> fixSubPaths opts args;
                     let ...;
                     .... }'
    In the second argument of `($)', namely
        `RepoJob
       $ \ (repo :: Repository p r u t)
             -> do { files <- if null args then
                                  return Nothing
                              else  Just <$> fixSubPaths opts args;
                     let ...;
                     .... }'
msg15368 (view) Author: bsrkaditya Date: 2012-03-20.12:18:17
The variable repo is of type Repository p C(r u t) in my copy of 
screened(Yours is Repository p r u t). You may have modified it before 
building?

 I have confirmed that the latest screened does not have this problem.
msg15369 (view) Author: fx Date: 2012-03-21.09:52:24
BSRK Aditya <bugs@darcs.net> writes:

> BSRK Aditya <bsrkaditya@gmail.com> added the comment:
>
> The variable repo is of type Repository p C(r u t) in my copy of 
> screened(Yours is Repository p r u t). You may have modified it before 
> building?

No, it's (still) from a fresh get, fixed by backing out

  Sun Mar 11 01:39:37 GMT 2012  Owen Stephens <darcs@owenstephens.co.uk>
    * Tidy up, refactor and comment Commands/WhatsNew

>  I have confirmed that the latest screened does not have this problem.

The web site says that's the same as the repo I'm using.  What is the
correct URL for it, and what is the repo at http://darcs.net that I've
been using for ages?
msg15372 (view) Author: owst Date: 2012-03-21.19:12:53
http://darcs.net is the screened repo. I've just fixed this bug, by
reverting to using C(r u r) as it should be.

bsrkaditya: the C(...) macro hides the type-variables when witnesses are
disabled; since it's a macro, once GHC sees the code, the macro's been
expanded as shown in fx's output...

This appears to only be a problem with older GHC (I'm using 7.0.4 and
have no warnings/errors).
msg15373 (view) Author: owst Date: 2012-03-21.19:42:22
I manually attached this patch, since I'm not on a machine that can send
patches... hopefully it will all turn out alright!
msg15535 (view) Author: noreply Date: 2012-04-05.21:15:50
The following patch sent by Owen Stephens <darcs@owenstephens.co.uk> updated issue issue2161 with
status=has-patch

* resolve issue2161 - don't use a separate type-variable for recorded/tentative in WhatsNew 
Ignore-this: 3da9d3b0e6a8d09d0c027c17d7c65548
GHC 6.12.1 would complain about binding distinct scoped type-variables to the
same type(-var) without this fix.
msg15536 (view) Author: ganesh Date: 2012-04-05.21:18:54
This got lost because it never went through the patch tracker - I've now 
applied it to the 2.8 branch and to head. It's not so important on head 
because 6.12.1 is no longer supported there, but the changed type is still 
the right one to have.
msg15684 (view) Author: noreply Date: 2012-05-14.13:10:06
The following patch sent by Owen Stephens <darcs@owenstephens.co.uk> updated issue issue2161 with
status=resolved;resolvedin=2.10.0 HEAD

* resolve issue2161 - don't use a separate type-variable for recorded/tentative in WhatsNew 
Ignore-this: 3da9d3b0e6a8d09d0c027c17d7c65548
GHC 6.12.1 would complain about binding distinct scoped type-variables to the
same type(-var) without this fix.
History
Date User Action Args
2012-03-19 21:24:36fxcreate
2012-03-20 12:18:17bsrkadityasetpriority: invalid
status: unknown -> wont-fix
messages: + msg15368
2012-03-21 09:52:26fxsetmessages: + msg15369
2012-03-21 17:54:53fxsetpriority: invalid -> bug
status: wont-fix -> unknown
2012-03-21 19:12:54owstsetstatus: unknown -> needs-implementation
messages: + msg15372
title: build failure -> screened repo build failure
2012-03-21 19:41:46owstsetfiles: + resolve-issue2151.dpatch
2012-03-21 19:41:52owstsetstatus: needs-implementation -> has-patch
2012-03-21 19:42:23owstsetmessages: + msg15373
2012-04-05 21:15:51noreplysetmessages: + msg15535
2012-04-05 21:18:56ganeshsetstatus: has-patch -> resolved
messages: + msg15536
resolvedin: 2.8.0
2012-05-14 13:10:07noreplysetmessages: + msg15684
resolvedin: 2.8.0 -> 2.10.0 HEAD