darcs

Issue 2238 darcs wh -ll suggests unadded files are added

Title darcs wh -ll suggests unadded files are added
Priority Status resolved
Milestone Resolved in 2.10.0 HEAD
Superseder Nosy List owst
Assigned To
Topics

Created on 2012-09-14.13:16:44 by owst, last changed 2012-12-21.10:02:51 by noreply.

Messages
msg16088 (view) Author: owst Date: 2012-09-14.13:16:43
Discovered by watermind and donri on IRC.

> darcs init
> touch foo
> darcs wh -ll
A ./foo

this 'A' suggests that foo has already been darcs add'd, yet:

> darcs wh -l
a ./foo

so, passing --look-for-adds twice does the wrong thing.
msg16409 (view) Author: ganesh Date: 2012-12-13.23:09:21
Looking at the code, I suspect that the problem is that optsModifier in 
whatsnewCmd in Darcs.UI.Commands.WhatsNew only deletes one instance of 
LookForAdds.
msg16448 (view) Author: noreply Date: 2012-12-21.10:02:50
The following patch sent by "Gian Piero Carrubba" <gpiero@rm-rf.it> updated issue issue2238 with
status=resolved;resolvedin=2.10.0 HEAD

* resolve issue2238: let optsModifier remove all occurrences of LookForAdds 
Ignore-this: 5e2d182727711288c8b0337d5e4a72bf
History
Date User Action Args
2012-09-14 13:16:44owstcreate
2012-12-13 23:09:22ganeshsetmessages: + msg16409
2012-12-21 10:02:51noreplysetstatus: unknown -> resolved
messages: + msg16448
resolvedin: 2.10.0 HEAD