darcs

Issue 2333 Error message when pushing and darcs not in path

Title Error message when pushing and darcs not in path
Priority bug Status resolved
Milestone 2.10.0 Resolved in 2.10.0
Superseder Nosy List brad.frank@gmail.com
Assigned To
Topics

Created on 2013-07-19.22:10:42 by brad.frank@gmail.com, last changed 2015-02-24.19:09:08 by noreply.

Messages
msg16920 (view) Author: brad.frank@gmail.com Date: 2013-07-19.22:10:41
1. Summarise the issue (what were doing, what went wrong?)
I was trying to push between one local repo with records, to another
repo with no records (empty repo). The error message I get is the following:
darcs: fd:9: hPutBuf: resource vanished (Broken pipe)

2. What behaviour were you expecting instead?
I was expecting for darcs to prompt me for each record/changeset, and to
ask me if I wanted it pushed or not, and it does, but then at the end it
fails and nothing is pushed.

3. What darcs version are you using? (Try: darcs --exact-version)
2.8.4

4. What operating system are you running?
Mac OS X 10.8
msg17917 (view) Author: bogdartysh Date: 2014-12-19.16:26:26
I have nearly the same:
$darcs push 

Pushing to "http://hub.darcs.net/bogdartysh/petitionsgrails"...
XXX
Exception thrown by an atexit registered action:
SignalException 13
darcs: fd:11: hPutBuf: resource vanished (Broken pipe)

OS: Ubuntu 14.04 LTS
remote repo is http://hub.darcs.net/
method of sending - http
msg17922 (view) Author: bf Date: 2014-12-30.14:49:47
I could not reproduce this with local repositories, so this seems to
happen only with remote repos. Here is my test:

mkdir -p R S
cd S; darcs init
cd ../R; darcs init
echo text > f
darcs record -lam 'added f'
PATH='' /home/ben/bin/darcs push ../S

It seems for local repos we do not call the external darcs via PATH
(which is reasonable: we want the same darcs we have been called with,
not a -- possibly different -- version from the PATH).
msg17953 (view) Author: bf Date: 2015-01-25.23:49:24
Strange, I just tried to reproduce again with a local repo and now I do
get the error with a slightly modified test.
msg18002 (view) Author: bf Date: 2015-02-04.23:00:13
I have sent a patch (Patch1249) that resolves this, it is in screened
and has the right patch name ("resolved issue2333: use getExecutablePath
instead of getProgName") but the automagic did not work :-( ....oh,
wait: does that have to be "resolve ...", not "resolved ..."?
msg18222 (view) Author: noreply Date: 2015-02-24.19:09:06
The following patch sent by Ben Franksen <benjamin.franksen@helmholtz-berlin.de> updated issue issue2333 with
status=resolved;resolvedin=2.10.0 HEAD

* resolved issue2333: use getExecutablePath instead of getProgName 
Ignore-this: 9c5853580509aa7a879f22462a8bafaf
History
Date User Action Args
2013-07-19 22:10:42brad.frank@gmail.comcreate
2014-12-19 16:26:27bogdartyshsetmessages: + msg17917
2014-12-30 14:49:49bfsetmessages: + msg17922
2015-01-25 23:49:25bfsetmessages: + msg17953
2015-02-04 23:00:14bfsetpriority: bug
status: unknown -> resolved
milestone: 2.10.0
messages: + msg18002
resolvedin: 2.10.0
2015-02-24 19:09:08noreplysetmessages: + msg18222