darcs

Issue 2429 convert export looses file

Title convert export looses file
Priority bug Status resolved
Milestone 2.10.0 Resolved in 2.10.0
Superseder Nosy List bf
Assigned To
Topics

Created on 2015-01-25.22:32:08 by bf, last changed 2015-02-02.20:42:35 by bf.

Messages
msg17952 (view) Author: bf Date: 2015-01-25.22:32:07
The test script tests/convert_export.sh exemplifies the problem. To see
what's wrong, run the test with --test-dir and in the resulting
gitmirror directory check the commits (e.g. git log --unified=1). The
second commit is wrong, it deletes the file d/f but does not create e/f.
This can also be seen if the pipe is replaced with a file, e.g.

darcs convert export --read-marks darcs-to-git.marks --write-marks
darcs-to-git.marks > fex2
(cd gitmirror && git fast-import --import-marks=git.marks
--export-marks=git.marks < ../fex2)

> grep e/f fex2
progress 2: Move d/f to e/f.
Move d/f to e/f.
D e/f

The cause of the problem seems to be that
Storage.Hashed.Monad.fileExists does not report True as it should.
msg17978 (view) Author: bf Date: 2015-02-02.20:42:34
Resolved by Patch1253, which was written to resolve issue2429, which had
the same reason, even though the symptoms were quite different.
History
Date User Action Args
2015-01-25 22:32:08bfcreate
2015-01-28 20:54:51bfsetpriority: bug
milestone: 2.10.0
2015-02-02 20:42:35bfsetstatus: unknown -> resolved
messages: + msg17978
resolvedin: 2.10.0