darcs

Issue 2437 cloning new repository with one patch from local path to ssh fails

Title cloning new repository with one patch from local path to ssh fails
Priority critical Status resolved
Milestone 2.10.0 Resolved in 2.10.0
Superseder Nosy List gh, jaredj
Assigned To
Topics ProbablyEasy

Created on 2015-02-11.19:40:27 by gh, last changed 2015-03-04.16:11:50 by bf.

Messages
msg18079 (view) Author: gh Date: 2015-02-11.19:40:24
This happens with current Darcs HEAD.

I don't think it's worthwile to write a regression test since it would
involve running a ssh server (in the case the test succeeds).

Here are the minimal steps to reproduce the bug:

```
/tmp$ darcs init R
/tmp$ cd R
/tmp/R$ echo x > x
/tmp/R$ darcs record -lam x
/tmp/R$ darcs clone . usr@host:path
Creating local clone...

darcs failed:  Couldn't fetch
`4e36eace85956d1aeb6749c5e889a88697535133ef507be5365d2303ad7ae9f7'
in subdir pristine.hashed from sources:

thisrepo:/tmp/clone/local
cache:/home/user/.cache/darcs
readonly:/home/user/.darcs/cache
```
msg18181 (view) Author: bf Date: 2015-02-20.12:45:35
See also issue2241. This is currently blocking me from using the HEAD at
work.
msg18182 (view) Author: bf Date: 2015-02-20.12:47:08
Sorry, typo. Meant to say: See issue2421.
msg18243 (view) Author: noreply Date: 2015-03-01.19:16:54
The following patch sent by Guillaume Hoffmann <guillaumh@gmail.com> updated issue issue2437 with
status=resolved;resolvedin=2.10.0 HEAD

* resolve issue2437: fix cloning to ssh by forgetting source repo later 
Ignore-this: bbc33f6cc6762c93bb4a60661073215c
msg18258 (view) Author: bf Date: 2015-03-04.13:42:04
It is not resolved. With the current HEAD I still get

franksen@elbe: ...epics/ioc/BII-Controls > darcs pull                       
Pulling from
"rcsadm@repo.acc.bessy.de:/opt/repositories/controls/darcs/epics/ioc/BII-Controls/base-3-14-12"...
darcs: failed to read patch:
patch cdaa8e60e7e632cfb072d06f48523d7db231a71f
Author: Sabine.Giray@helmholtz-berlin.de.de
Date:   Wed Mar  4 13:40:25 CET 2015
  * minor changes (RFApp)
Couldn't fetch
`0000001156-372a52661eb9c63ff8a7b4e37530646808c626509c3d4b41d9ceb5919b5bfa94'
in subdir patches from sources:

thisrepo:/srv/projects/ctl/franksen/epics/ioc/BII-Controls
cache:/home/franksen/.cache/darcs
cache:/opt/csr/share/cache/darcs
cache:/tmp/darcs-franksen/cache
repo:rcsadm@repo.acc.bessy.de:/opt/repositories/controls/darcs/epics/ioc/BII-Controls/base-3-14-12
msg18259 (view) Author: bf Date: 2015-03-04.13:43:38
See also issue2421 and issue2400, which are more or less duplicates.
msg18260 (view) Author: gh Date: 2015-03-04.15:25:01
Clearly it's a different bug from 2421, and I believe ticket 2400 is a
mix of the current ticket's bug (which *is* resolved) and of 2421 (but I
suspect it has already been open before).
msg18261 (view) Author: gh Date: 2015-03-04.15:27:22
The current bug is about cloning from a local repo to a ssh destination
only, not pulling or cloning from http.
msg18262 (view) Author: bf Date: 2015-03-04.16:11:10
In that case: sorry for mixing things up. I thought it must be the same
problem because of the very similar error message.
History
Date User Action Args
2015-02-11 19:40:27ghcreate
2015-02-20 12:45:37bfsetpriority: critical
messages: + msg18181
2015-02-20 12:47:10bfsetmessages: + msg18182
2015-03-01 19:16:55noreplysetstatus: unknown -> resolved
messages: + msg18243
resolvedin: 2.10.0
2015-03-04 13:42:06bfsetstatus: resolved -> (no value)
messages: + msg18258
2015-03-04 13:43:40bfsetstatus: unknown
messages: + msg18259
2015-03-04 15:25:03ghsetstatus: unknown -> resolved
messages: + msg18260
2015-03-04 15:27:23ghsetstatus: resolved -> unknown
messages: + msg18261
2015-03-04 15:33:18ghsetstatus: unknown -> resolved
2015-03-04 16:11:11bfsetstatus: resolved -> unknown
messages: + msg18262
2015-03-04 16:11:50bfsetstatus: unknown -> resolved