darcs

Issue 2459 cloning remote repo fails to use packs if cache is on a different partition

Title cloning remote repo fails to use packs if cache is on a different partition
Priority Status resolved
Milestone Resolved in 2.12.0
Superseder Nosy List bf
Assigned To
Topics

Created on 2015-06-24.21:58:30 by bf, last changed 2015-10-16.19:53:54 by noreply.

Messages
msg18621 (view) Author: bf Date: 2015-06-24.21:58:28
I just tried to clone a remote repo that I 'optimize http'-ed before and
it told me "Problem while copying basic pack, copying normally."

Investigating this, I removed the catchall handler that hides the
underlying OS error (in D.R.Clone) and found that the problem is:

darcs:
/home/ben/.cache/darcs/pristine.hashed/fb/fbc32994b8c855359a0eca70ade35f39c2e81fead62f74a79de1ec8bcd07c536:
createLink: unsupported operation (Invalid cross-device link)

No wonder this fails: /tmp has its own partition. The createLink call is
from D.R.Packs. I think the proper fix is to fall back to writing the
file, which is what normally happens if ~/.cache/... does not exist.
msg18624 (view) Author: gh Date: 2015-06-25.16:28:15
It would be nice to have a fix for that in 2.10.1, seems like a one-liner.

2015-06-24 18:58 GMT-03:00 Ben Franksen <bugs@darcs.net>:
>
> New submission from Ben Franksen <benjamin.franksen@helmholtz-berlin.de>:
>
> I just tried to clone a remote repo that I 'optimize http'-ed before and
> it told me "Problem while copying basic pack, copying normally."
>
> Investigating this, I removed the catchall handler that hides the
> underlying OS error (in D.R.Clone) and found that the problem is:
>
> darcs:
> /home/ben/.cache/darcs/pristine.hashed/fb/fbc32994b8c855359a0eca70ade35f39c2e81fead62f74a79de1ec8bcd07c536:
> createLink: unsupported operation (Invalid cross-device link)
>
> No wonder this fails: /tmp has its own partition. The createLink call is
> from D.R.Packs. I think the proper fix is to fall back to writing the
> file, which is what normally happens if ~/.cache/... does not exist.
>
> ----------
> messages: 18621
> nosy: bf
> status: unknown
> title: cloning remote repo fails to use packs if cache is on a different partition
>
> __________________________________
> Darcs bug tracker <bugs@darcs.net>
> <http://bugs.darcs.net/issue2459>
> __________________________________
> _______________________________________________
> darcs-devel mailing list
> darcs-devel@darcs.net
> http://lists.osuosl.org/mailman/listinfo/darcs-devel
msg18786 (view) Author: noreply Date: 2015-10-16.19:17:40
The following patch sent by Ben Franksen <benjamin.franksen@helmholtz-berlin.de> updated issue issue2459 with
status=resolved;resolvedin=2.12.0 HEAD

* resolve issue2459: fall back to writing the file if createLink fails 
Ignore-this: 15dd4c093dbe864fe2be1a1e3c6a1320
msg18789 (view) Author: gh Date: 2015-10-16.19:35:18
Sorry for the mixup (I wrongly pushed patches to reviewed), this issue
remains open.
msg18791 (view) Author: gh Date: 2015-10-16.19:38:05
And ... it is resolved after all. Sorry x 2.
msg18793 (view) Author: noreply Date: 2015-10-16.19:53:53
The following patch sent by Ben Franksen <benjamin.franksen@helmholtz-berlin.de> updated issue issue2459 with
status=resolved;resolvedin=2.12.0 HEAD

* resolve issue2459: fall back to writing the file if createLink fails 
Ignore-this: 15dd4c093dbe864fe2be1a1e3c6a1320
History
Date User Action Args
2015-06-24 21:58:30bfcreate
2015-06-25 16:28:17ghsetmessages: + msg18624
2015-10-16 19:17:41noreplysetstatus: unknown -> resolved
messages: + msg18786
resolvedin: 2.12.0
2015-10-16 19:35:19ghsetstatus: resolved -> unknown
messages: + msg18789
resolvedin: 2.12.0 -> (no value)
2015-10-16 19:38:07ghsetstatus: unknown -> resolved
messages: + msg18791
resolvedin: 2.12.0
2015-10-16 19:53:54noreplysetmessages: + msg18793