darcs

Issue 2652 `darcs convert import` double-encodes cyrillic characters in UTF-8 input stream

Title `darcs convert import` double-encodes cyrillic characters in UTF-8 input stream
Priority Status duplicate
Milestone Resolved in
Superseder `darcs convert import` double-encodes cyrillic characters in UTF-8 input stream
View: 2648
Nosy List korobkov
Assigned To
Topics

Created on 2020-08-08.03:00:13 by korobkov, last changed 2020-08-09.19:33:55 by ganesh.

Messages
msg22397 (view) Author: korobkov Date: 2020-08-08.03:00:10
When converting git repo containing cyrillic characters in filenames
and/or patch names into darcs repo these characters looks like double
encoded.

Tested with default version from ports tree:
% darcs --exact-version
darcs compiled on May 15 2020, at 04:54:49

Weak Hash: not available

Context:

[TAG 2.14.2
Ganesh Sittampalam <ganesh@earth.li>**20190126112346
 Ignore-this: 5c94e042fbcfdf311008d6e980d9cf1d
]

And also with custom repo:https://urchin.earth.li/darcs/ganesh/temp/darcs-import-utf8-hack

patch a089edf27367f5698dad15ed20d28dd803fb156a
Author: Ganesh Sittampalam <ganesh@earth.li>
Date:   Wed Jun 10 01:58:21 +04 2020
  * TEST: assume imported patch metadata is UTF8 not Char8


Running on FreeBSD 12.1
--
Andrey Korobkov
msg22399 (view) Author: ganesh Date: 2020-08-08.09:01:25
This is a duplicate of issue2648 - maybe mail system duplication somewhere.
msg22424 (view) Author: korobkov Date: 2020-08-09.18:39:03
Ganesh Sittampalam <bugs@darcs.net> writes:

> Ganesh Sittampalam <ganesh@earth.li> added the comment:
>
> This is a duplicate of issue2648 - maybe mail system duplication somewhere.
>
> ----------
> status: unknown -> duplicate
> superseder: +`darcs convert import` double-encodes cyrillic characters in UTF-8 input stream
>
> __________________________________
> Darcs bug tracker <bugs@darcs.net>
> <http://bugs.darcs.net/issue2652>
> __________________________________

I first sent bug report via email. But as it wasn't published, I thought
something wasn't working as expected and had to resent it via HTTP
(bugtracker).
Now it looks like I just had to wait some more time and all would be OK
with email, just as expected.

sorry for involuntary duplication,
-- 
Andrey Korobkov
msg22425 (view) Author: ganesh Date: 2020-08-09.19:33:53
> I first sent bug report via email. But as it wasn't published, I thought
> something wasn't working as expected and had to resent it via HTTP
> (bugtracker).
> Now it looks like I just had to wait some more time and all would be OK
> with email, just as expected.
> 
> sorry for involuntary duplication,

No problem. If this one is the report that came from your email then I'm
glad you didn't wait! That's a pretty extreme delay.
History
Date User Action Args
2020-08-08 03:00:13korobkovcreate
2020-08-08 09:01:28ganeshsetstatus: unknown -> duplicate
superseder: + `darcs convert import` double-encodes cyrillic characters in UTF-8 input stream
messages: + msg22399
2020-08-09 18:39:06korobkovsetmessages: + msg22424
2020-08-09 19:33:55ganeshsetmessages: + msg22425