darcs

Issue 431 wish: darcs init/get --no-working-directory

Title wish: darcs init/get --no-working-directory
Priority feature Status resolved
Milestone Resolved in 2.8.0
Superseder overhaul format mechanism: local and optional formats
View: 1647
Nosy List WorldMaker, darcs-devel, dmitry.kurochkin, galbolle, kowey, mornfall, premchai21, thorkilnaur, tommy, twb
Assigned To galbolle
Topics

Created on 2007-04-14.21:54:43 by WorldMaker, last changed 2013-05-09.21:41:50 by gh.

Messages
msg1585 (view) Author: WorldMaker Date: 2007-04-14.21:54:39
It would be useful in the case of immutable repositories (repositories for 
tools like darcs get mainly, with all mutating commands --disabled in 
defaults) to be stored without any of the files in its working directory.  
Thus the only overhead for the immutable repository would be _darcs-related, 
much of which can be linked by darcs get/optimize already.

The primary use case scenario would be you might wish to store a repository at 
a certain point in time, be it a tag repository (darcs get --tag --no-working-
directory) or just a current snapshot repository (darcs get --no-working-
directory).  This immutable repository (again, adding enforcing lines to 
_darcs/prefs/defaults) could then still be useful to tools like darcsweb that 
rely on the pristine cache rather than the working directory and in use with 
darcs get/pull.

Admittedly, having no working directory may often not be a huge space savings, 
but the lack of files in the working directory is a very obvious hint to other 
developers that the repository is in fact immutable and not meant for editing 
of any sort.
msg1670 (view) Author: kowey Date: 2007-05-02.07:10:19
This might also be useful for people who want to use darcs in a centralised
manner, i.e. having a push/pull depot used exclusively for sharing patches.

The key feature here is, as Max says, to hint that the repository is not meant
for editing of any sort.

I suppose we would have to make sure that the user never tries to create a
repository with --no-pristine-cache --no-working-directory.
msg1671 (view) Author: droundy Date: 2007-05-02.19:56:09
Just wanted to mention that I like this idea.  It shouldn't be too hard,
although I'd want to use the RepoFormat bit to ensure that older versions
of darcs don't try to modify working-directory-less repositories.
-- 
David Roundy
Department of Physics
Oregon State University
msg7014 (view) Author: kowey Date: 2009-01-08.11:48:07
Maybe we should resurrect (un-defer) this to replace the --no-pristine-tree
(which was recently removed because it doesn't work with hashed repositories anyway)
msg7173 (view) Author: twb Date: 2009-01-24.11:58:04
Eric Kow wrote:
> To be merged with issue431?

Yes, I reported this because I couldn't find 431, and guessed it wasn't in the BTS.

I have merged them with this mail.
msg8953 (view) Author: kowey Date: 2009-10-11.07:57:16
My understanding is that this requires implementation of issue1647.
msg16802 (view) Author: gh Date: 2013-05-09.21:41:48
It has been solved in 2.8 by Florent's patch "Support init/get --no-
working-dir and pseudo-applying to wd-less repos".
History
Date User Action Args
2007-04-14 21:54:43WorldMakercreate
2007-05-02 07:10:39koweysetstatus: unread -> unknown
nosy: droundy, tommy, beschmi, kowey, WorldMaker
messages: + msg1670
2007-05-02 19:56:13droundysetnosy: droundy, tommy, beschmi, kowey, WorldMaker
messages: + msg1671
2007-07-22 07:27:48koweysettopic: + ProbablyEasy
nosy: droundy, tommy, beschmi, kowey, WorldMaker
2008-02-09 18:14:35markstossetstatus: unknown -> deferred
nosy: droundy, tommy, beschmi, kowey, WorldMaker
title: darcs get --no-working-directory -> wish: darcs get --no-working-directory
2009-01-08 11:48:11koweysetstatus: deferred -> needs-reproduction
nosy: + dmitry.kurochkin, simon, thorkilnaur
messages: + msg7014
2009-01-24 11:58:07twbsetsuperseder: + wish: darcs init --no-working-tree
messages: + msg7173
nosy: + twb
2009-08-06 17:35:34adminsetnosy: + markstos, jast, Serware, darcs-devel, zooko, dagit, mornfall, - droundy, twb, WorldMaker
2009-08-06 20:32:43adminsetnosy: - beschmi
2009-08-10 22:02:50adminsetnosy: + WorldMaker, twb, - markstos, darcs-devel, zooko, jast, dagit, Serware, mornfall
2009-08-18 22:50:35koweylinkissue1328 superseder
2009-08-18 22:52:15koweysetstatus: needs-reproduction -> needs-implementation
topic: - ProbablyEasy
title: wish: darcs get --no-working-directory -> wish: darcs init/get --no-working-directory
nosy: + mornfall
priority: wishlist -> feature
superseder: - wish: darcs init --no-working-tree
2009-08-23 18:07:54koweylinkissue555 superseder
2009-08-25 17:38:24adminsetnosy: + darcs-devel, - simon
2009-08-27 14:30:58adminsetnosy: tommy, kowey, darcs-devel, twb, WorldMaker, thorkilnaur, dmitry.kurochkin, mornfall
2009-10-11 07:57:18koweysetstatus: needs-implementation -> waiting-for
nosy: tommy, kowey, darcs-devel, twb, WorldMaker, thorkilnaur, dmitry.kurochkin, mornfall
superseder: + overhaul format mechanism: local and optional formats
messages: + msg8953
2009-10-23 22:39:07adminsetnosy: + maxbattcher, - WorldMaker
2009-10-24 00:00:29adminsetnosy: + WorldMaker, - maxbattcher
2010-10-16 10:24:35koweysetstatus: waiting-for -> has-patch
assignedto: galbolle
nosy: + galbolle
2010-11-02 23:05:51ganeshlinkpatch424 issues
2011-06-25 04:47:29premchai21setnosy: + premchai21
2013-05-09 21:41:50ghsetstatus: has-patch -> resolved
messages: + msg16802
resolvedin: 2.8.0