darcs

Issue 762 More usable messages for darcs unpull

Title More usable messages for darcs unpull
Priority feature Status duplicate
Milestone Resolved in
Superseder say when patches are automatically pre-selected due to dependencies
View: 337
Nosy List darcs-devel, dmitry.kurochkin, kowey, markstos, thorkilnaur, tim, tommy
Assigned To
Topics Matchers, UI

Created on 2008-03-26.17:20:43 by tim, last changed 2009-09-04.09:40:20 by kowey.

Messages
msg4035 (view) Author: tim Date: 2008-03-26.17:20:41
If you "darcs unpull" a patch, say with:

darcs unpull --match='name quux'

darcs may well ask you whether you unpull a patch named, say, "foo". If you say
yes, it will then ask you whether you want to unpull "quux". If you say no, the
whole operation aborts. I find this highly confusing, since I don't always know
offhand which patches depend on which ones. I understand (now, anyway; this held
me up for quite a while) that it's because foo depends on quux. But it would
help a lot if darcs printed out a message saying something like,  "foo depends
on quux, so you must unpull foo in order to unpull quux."
msg5456 (view) Author: markstos Date: 2008-08-13.01:52:14
I agree with this 'wish' but am marking it as 'deferred' for now, since it's a
wishlist item.
msg8679 (view) Author: kowey Date: 2009-09-04.09:39:59
I claim that this is actually a duplicate of issue337 (which I now think falsely
claims to be a duplicate of issue125).  Merging.
History
Date User Action Args
2008-03-26 17:20:43timcreate
2008-08-13 01:52:18markstossetstatus: unread -> deferred
nosy: + markstos, dagit
messages: + msg5456
title: More usable messages for darcs unpull -> wish: More usable messages for darcs unpull
2009-08-06 21:01:06adminsetnosy: + dmitry.kurochkin, simon, thorkilnaur, - beschmi
2009-08-11 00:09:00adminsetnosy: - dagit
2009-08-25 18:09:32adminsetnosy: + darcs-devel, - simon
2009-08-27 14:02:42adminsetnosy: tommy, kowey, markstos, darcs-devel, tim, thorkilnaur, dmitry.kurochkin
2009-09-04 09:40:05koweysetstatus: deferred -> duplicate
topic: + UI, Matchers
title: wish: More usable messages for darcs unpull -> say when patches are automatically pre-selected due to dependencies
nosy: tommy, kowey, markstos, darcs-devel, tim, thorkilnaur, dmitry.kurochkin
messages: + msg8679
priority: wishlist -> feature
superseder: + say when patches are automatically pre-selected due to dependencies
2009-09-04 09:40:20koweysetnosy: tommy, kowey, markstos, darcs-devel, tim, thorkilnaur, dmitry.kurochkin
title: say when patches are automatically pre-selected due to dependencies -> More usable messages for darcs unpull