Patch 1649 darcs.cabal: add Version to autogen-modules

Title darcs.cabal: add Version to autogen-modules
Superseder Nosy List bf
Related Issues
Status needs-review Assigned To

Created on 2018-02-18.22:44:47 by bf, last changed 2018-03-18.21:27:26 by bf.

File name Status Uploaded Type Edit Remove
darcs_cabal_-add-version-to-autogen_modules.dpatch bf, 2018-02-18.22:44:47 application/x-darcs-patch
See mailing list archives for discussion on individual patches.
msg19903 (view) Author: bf Date: 2018-02-18.22:44:47
This patch lets me use cabal-head with ghc-8.2.2. Might work or not with
other cabal versions.

1 patch for repository http://darcs.net/screened:

patch 7780cac707d9fe363ca6eed9a7611b81256b0441
Author: Ben Franksen <ben.franksen@online.de>
Date:   Thu Feb 15 09:44:08 CET 2018
  * darcs.cabal: add Version to autogen-modules
msg19928 (view) Author: ganesh Date: 2018-03-04.11:55:22
I also have a patch like this locally but I had some trouble with older 
cabals and am a bit confused by whether it should work or not.
msg19986 (view) Author: bf Date: 2018-03-18.21:27:26
Screening this now since it works with ghc-8.0, too, and I just just
checked that it also does no harm to cabal-1.24.
Date User Action Args
2018-02-18 22:44:47bfcreate
2018-03-04 11:55:22ganeshsetmessages: + msg19928
2018-03-18 21:27:26bfsetstatus: needs-screening -> needs-review
messages: + msg19986