darcs

Patch 1657 Support GHC 8.4

Title Support GHC 8.4
Superseder Nosy List ganesh
Related Issues
Status accepted Assigned To
Milestone

Created on 2018-02-28.07:11:42 by ganesh, last changed 2018-03-23.21:05:53 by gh.

Files
File name Status Uploaded Type Edit Remove
support-base-4_11-_ghc-8_4_.dpatch ganesh, 2018-02-28.07:11:42 application/octet-stream
support-base-4_11-_ghc-8_4_.dpatch gh, 2018-03-09.20:37:20 application/octet-stream
See mailing list archives for discussion on individual patches.
Messages
msg19923 (view) Author: ganesh Date: 2018-02-28.07:11:42
Bump the base dependency so we can build with GHC 8.4 - depends on 
the relevant code changes submitted in other patches.

There are also some changes needed to support newer Cabal versions 
that may or may not come along with GHC 8.4, but I'm getting very 
confused about compatibility of those changes, so not submitting 
them yet.
Attachments
msg19924 (view) Author: bf Date: 2018-03-03.13:47:40
Re newer cabal versions see also patch1649 .
msg19956 (view) Author: gh Date: 2018-03-09.20:28:04
Let us directly accept this patch and continue the Cabal talk with
http://bugs.darcs.net/patch1649 .
msg19957 (view) Author: gh Date: 2018-03-09.20:37:20
Accepting the attached rebased version (there were changes in darcs.cabal).
Attachments
History
Date User Action Args
2018-02-28 07:11:42ganeshcreate
2018-03-03 13:47:40bfsetmessages: + msg19924
2018-03-09 20:28:04ghsetstatus: needs-screening -> accepted
messages: + msg19956
2018-03-09 20:37:20ghsetfiles: + support-base-4_11-_ghc-8_4_.dpatch
messages: + msg19957
2018-03-09 20:37:52ghsetstatus: accepted -> accepted-pending-tests
2018-03-23 21:05:53ghsetstatus: accepted-pending-tests -> accepted