Here is a first batch of preparation patches extracted from my invertible
branch.
13 patches for repository http://darcs.net/screened:
patch cfc73aaf7cb42795fd6abec946ace2aa20147570
Author: Ben Franksen <ben.franksen@online.de>
Date: Thu Aug 29 18:39:18 CEST 2019
* re-export all imported classes (with members) from Darcs.Patch.RepoPatch
patch 6c34c6f7d916c1bf22cd806b8160841c8604e652
Author: Ben Franksen <ben.franksen@online.de>
Date: Fri Aug 30 10:04:59 CEST 2019
* matching a patch should be invariant under inversion
This adds a property (only in the haddocks) to D.P.Match.matchAPatch and
removes re-inversion of patches when we apply a match criterion from
D.UI.SelectChanges.
patch 2b18986569ec2db53f2f21b3e74ac9ebf390b89d
Author: Ben Franksen <ben.franksen@online.de>
Date: Fri Aug 30 10:15:13 CEST 2019
* rename repr to reInvert and fix its haddocks
patch c1be3d805cadcee2e7707521bdbdebb5d7ce360f
Author: Ben Franksen <ben.franksen@online.de>
Date: Tue Sep 10 10:17:42 CEST 2019
* remove bogus ReadPatch instances for RebaseSelect and RebaseChange
patch d1135c89f45516f6fe31f6fcf16f6875cea1ab1f
Author: Ben Franksen <ben.franksen@online.de>
Date: Thu Sep 12 10:58:41 CEST 2019
* cleanups in log command
patch 432438798e2bb1b8851722ee751f4b82bfb5df60
Author: Ben Franksen <ben.franksen@online.de>
Date: Fri Aug 30 10:04:30 CEST 2019
* add TODO items to Darcs.Patch.Inspect
patch 91d85f940bafa1343183ee936cd2d99aa091e47a
Author: Ben Franksen <ben.franksen@online.de>
Date: Tue Sep 3 00:04:50 CEST 2019
* fix broken layout of Darcs.Patch.Named.readNamed
patch b561f5211bc6a4ebe6cdcad7a3918bf8f0e9fa90
Author: Ben Franksen <ben.franksen@online.de>
Date: Tue Sep 17 13:41:26 CEST 2019
* SelectChanges: simplify currentPatch and todo using WZipper tools
patch da33da8087705ca7386df89272e378101bdf463b
Author: Ben Franksen <ben.franksen@online.de>
Date: Sat Aug 31 00:19:22 CEST 2019
* remove Invert constraint from Matchable and MatchableRP
This means we need to add it to a a few function that actually require it.
We do this as a preparation for eventually removing Invert instances from
all the higher level patch types.
patch 09b5e47e317b840d05382951c35a39e4b624068c
Author: Ben Franksen <ben.franksen@online.de>
Date: Wed Sep 11 11:40:47 CEST 2019
* rename patches_context to selection_context in rebase command
patch 6e72aa1695ffdc7fd5430cd1748d2d5424e1651d
Author: Ben Franksen <ben.franksen@online.de>
Date: Sun Sep 1 22:03:34 CEST 2019
* use showPatch ForStorage in V3 error messages
patch 97ab5fb888bc9c670ef78b57131a1edf20b840ad
Author: Ben Franksen <ben.franksen@online.de>
Date: Tue Sep 10 12:01:55 CEST 2019
* remove superclass Commute from class Merge
patch 6a37fd022710f904ddb06ae7f141b44fed770102
Author: Ben Franksen <ben.franksen@online.de>
Date: Tue Sep 10 12:19:44 CEST 2019
* avoid redundant constraints warnings for default methods of FromPrim
> * re-export all imported classes (with members) from
> Darcs.Patch.RepoPatch
> * matching a patch should be invariant under inversion
> * rename repr to reInvert and fix its haddocks
> * remove bogus ReadPatch instances for RebaseSelect and RebaseChange
> * cleanups in log command
Fine
> * add TODO items to Darcs.Patch.Inspect
FWIW I think making listTouchedFiles invariant would also affect the UI of -
-match.
> * fix broken layout of Darcs.Patch.Named.readNamed
> * SelectChanges: simplify currentPatch and todo using WZipper tools
Fine
> * remove Invert constraint from Matchable and MatchableRP
Fine
> * rename patches_context to selection_context in rebase command
Fine. For what it's worth I think it was named as such to distinguish when
we are operating on patches rather than primitive changes, such as in rebase
inject.
> * use showPatch ForStorage in V3 error messages
> * remove superclass Commute from class Merge
Fine
> * avoid redundant constraints warnings for default methods of FromPrim
Fine. I guess this is technically a behaviour change if in future there
were any implementors of the class that defined fromPrim but not fromPrims,
but it seems like a good one anyway.
>> * add TODO items to Darcs.Patch.Inspect
>
> FWIW I think making listTouchedFiles invariant would also affect the UI of -
> -match.
I don't really have any concrete ideas what to do about this one (or
whether). Just wanted to remind us that some day we may want to revise
that API.
> Fine. For what it's worth I think it was named as such to distinguish when
> we are operating on patches rather than primitive changes, such as in rebase
> inject.
I see. I was confused by the name, it sounds like "the context of these
patches" which would be the patches preceding them...
Perhaps we should rename SelectionContext to something less overloaded,
like SelectionConfig?