darcs

Issue 2536 show files --no-files: can't mix match and pending flags

Title show files --no-files: can't mix match and pending flags
Priority Status unknown
Milestone 2.15.0 HEAD Resolved in 2.15.0 HEAD
Superseder Nosy List bf
Assigned To
Topics

Created on 2017-04-22.05:08:49 by bf, last changed 2018-08-25.17:08:57 by bf.

Messages
msg19489 (view) Author: bf Date: 2017-04-22.05:08:48
Note: no further options have been supplied. I do have a (rebase)
suspended patch. The problem is that 
Darcs.Patch.Match.haveNonrangeMatch returns True even if there are no
match flags present. This is caused by addInternalMatcher from
Darcs.Patch.Match. It is unclear to me what the purpose of this
'internal matcher' is.
msg20212 (view) Author: bf Date: 2018-07-19.10:52:53
This is fixed now, I guess by the refactor of PatchSet matching, see
patch1707.
msg20243 (view) Author: ganesh Date: 2018-08-09.05:55:07
I think addInternalMatcher is a hack to stop the rebase patch being 
picked up by range matching. Hopefully your refactor avoids that in a 
better way now.
msg20244 (view) Author: ganesh Date: 2018-08-09.06:09:20
Reverting accidental state change from my last comment.
msg20261 (view) Author: bf Date: 2018-08-25.17:08:55
I was wrong. As pointed out by Gian Piero Carrubba <gpiero@rm-rf.it>:

> If it superseded patch 92a33eb6558f1d0d2d363bd0b2411a50280fc31d please
> consider committing a rollback of the latter, as it was a terrible hack.

It does not superseed your patch, which is a correct fix, if not the
most beautiful solution.

> Also, please note that tests/issue2536-show-files--no-files.sh does not
> seem to test the right thing, as the problem was caused by an
> on-progress rebase. The test for 2501 / 2536 was included in
> tests/show_files.sh (patch 03c49a7741904ca55fb5247cd6fa4ec4c1a1da20)

Right. Should we remove the bogus test?
History
Date User Action Args
2017-04-22 05:08:49bfcreate
2018-01-29 19:37:34gpierolinkpatch1638 issues
2018-07-19 10:52:54bfsetstatus: unknown -> resolved
messages: + msg20212
milestone: 2.15.0 HEAD
2018-07-19 10:57:38bfsetresolvedin: 2.15.0 HEAD
2018-08-09 05:55:09ganeshsetstatus: resolved -> unknown
messages: + msg20243
2018-08-09 06:09:21ganeshsetstatus: unknown -> resolved
messages: + msg20244
2018-08-25 17:08:57bfsetstatus: resolved -> unknown
messages: + msg20261